Mailinglist Archive: opensuse-updates (174 mails)

< Previous Next >
openSUSE-RU-2015:2104-1: moderate: Recommended update for ruby-common
openSUSE Recommended Update: Recommended update for ruby-common
______________________________________________________________________________

Announcement ID: openSUSE-RU-2015:2104-1
Rating: moderate
References: #934328 #953771
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that has two recommended fixes can now be
installed.

Description:

This update for ruby-common provides several fixes and enhancements:

- Help the solver to pick the right gem2rpm for the default Ruby version.
(bsc#934328)
- Fix premature return from from gem install.
- Fail early if gem install fails, avoiding confusing error messages at
the end of the build.
- Implement cleaner solution for the extensions doc dir.
- Do not overwrite options.otheropts.
- Fixed forwarding of options to gem install.
- Call ruby with -x from shell wrappers otherwise it might run into an
endless loop.
- Add shell-launcher to avoid dependency on a fixed Ruby version.
- Ignore any files found in */.gem/*. In some versions of rubygems, gems
that are installed are also copied to ~/.gem/.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2015-809=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (noarch):

ruby-common-2.1-5.1


References:

https://bugzilla.suse.com/934328
https://bugzilla.suse.com/953771


< Previous Next >
This Thread
  • No further messages