Mailinglist Archive: opensuse-updates (64 mails)

< Previous Next >
openSUSE-SU-2015:1028-1: moderate: Security update for zeromq
openSUSE Security Update: Security update for zeromq
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:1028-1
Rating: moderate
References: #907584 #912460 #931978
Cross-References: CVE-2014-9721
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

zeromq was updated to fix one security issue and two non-security bugs.

The following vulnerabilities were fixed:

* CVE-2014-9721: zeromq protocol downgrade attack on sockets using the
ZMTP v3 protocol (boo#931978)

The following bugs were fixed:

* boo#912460: avoid curve test to hang for ppc ppc64 ppc64le architectures
* boo#907584: zeromq package could not be updated due to a file conflict,
split tools into a separate subpackage


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-409=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-409=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libzmq4-4.0.5-3.9.1
libzmq4-debuginfo-4.0.5-3.9.1
zeromq-debugsource-4.0.5-3.9.1
zeromq-devel-4.0.5-3.9.1
zeromq-tools-4.0.5-3.9.1
zeromq-tools-debuginfo-4.0.5-3.9.1

- openSUSE 13.1 (i586 x86_64):

libzmq4-4.0.5-4.7.1
libzmq4-debuginfo-4.0.5-4.7.1
zeromq-debugsource-4.0.5-4.7.1
zeromq-devel-4.0.5-4.7.1
zeromq-tools-4.0.5-4.7.1
zeromq-tools-debuginfo-4.0.5-4.7.1


References:

https://www.suse.com/security/cve/CVE-2014-9721.html
https://bugzilla.suse.com/907584
https://bugzilla.suse.com/912460
https://bugzilla.suse.com/931978


< Previous Next >
This Thread
  • No further messages