Mailinglist Archive: opensuse-updates (64 mails)

< Previous Next >
openSUSE-RU-2015:1010-1: moderate: Recommended update for patch
openSUSE Recommended Update: Recommended update for patch
______________________________________________________________________________

Announcement ID: openSUSE-RU-2015:1010-1
Rating: moderate
References: #918058
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that has one recommended fix can now be installed.

Description:

GNU patch was updated to 2.7.5 to fix a functional regression introduced
by the previous security fix.

The following bugs were fixed:

* The security fix would forbid legitimate use cases of relative symbolic
links. [boo#918058]

The following changes are included:

* Do not change permissions if there isn't an explicit mode change.
* Fix indentation heuristic for context diffs.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-405=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-405=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

patch-2.7.5-7.7.1
patch-debuginfo-2.7.5-7.7.1
patch-debugsource-2.7.5-7.7.1

- openSUSE 13.1 (i586 x86_64):

patch-2.7.5-4.7.1
patch-debuginfo-2.7.5-4.7.1
patch-debugsource-2.7.5-4.7.1


References:

https://bugzilla.suse.com/918058


< Previous Next >
This Thread
  • No further messages