Mailinglist Archive: opensuse-updates (98 mails)

< Previous Next >
openSUSE-SU-2015:0628-1: moderate: Security update for rubygem-bundler
openSUSE Security Update: Security update for rubygem-bundler
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:0628-1
Rating: moderate
References: #898205
Cross-References: CVE-2013-0334
Affected Products:
openSUSE 13.2
openSUSE 13.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

rubygem-bunder was updated to fix security vulnerabilities and
non-security issues

The following security issues were fixed:

* Hide credentials while warning about gems with ambiguous sources
* Warn when more than one top-level source is present
* Bundler may install gems from a different source than expected
(CVE-2013-0334) (bnc#898205)

In addition, rubygem-bundler was udpated to 1.8.4 to fix non-security
issues.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-275=1

- openSUSE 13.1:

zypper in -t patch openSUSE-2015-275=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

rubygem-bundler-1.8.4-2.4.1
rubygem-bundler-doc-1.8.4-2.4.1

- openSUSE 13.1 (i586 x86_64):

rubygem-bundler-1.8.4-3.4.1
rubygem-bundler-doc-1.8.4-3.4.1


References:

https://www.suse.com/security/cve/CVE-2013-0334.html
https://bugzilla.suse.com/898205


< Previous Next >
This Thread
  • No further messages