Mailinglist Archive: opensuse-updates (98 mails)

< Previous Next >
openSUSE-RU-2015:0586-1: moderate: Recommended update for kdevelop
openSUSE Recommended Update: Recommended update for kdevelop
______________________________________________________________________________

Announcement ID: openSUSE-RU-2015:0586-1
Rating: moderate
References:
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that has 0 recommended fixes can now be installed.

Description:

This recommended update for kdevelop fixes the following issues:
- kdevelop4:
+ Update to bugfix release 4.7.1 (No upstream changelog provided)
+ Require libktexteditor instead of kate, that package provides plugins
used by kdevelop, and allows co-installability of kate5 and kdevelop4
+ Fix bashisms in post/postun scripts
+ Split the cpp support from the kdevelop4 package. The cpp and Clang
plugins are mutually exclusive. Moving the cpp plugin to its own
package allows installing the experimental clang package.
+ Fix some rpmlint warnings

- kdevplatform, kdevelop4-plugins and kdevelop-plugins-python
+ Update to bugfix release 1.7.1 (No upstream changelog provided)

- kdevelop4-pg-qt
+ Fix warnings to resolve the current build errors


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-258=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

kdevelop4-4.7.1-4.1
kdevelop4-debuginfo-4.7.1-4.1
kdevelop4-debugsource-4.7.1-4.1
kdevelop4-devel-4.7.1-4.1
kdevelop4-doc-4.7.1-4.1
kdevelop4-pg-qt-1.0.0-10.5.1
kdevelop4-pg-qt-debuginfo-1.0.0-10.5.1
kdevelop4-pg-qt-debugsource-1.0.0-10.5.1
kdevelop4-plugin-cppsupport-4.7.1-4.1
kdevelop4-plugin-cppsupport-debuginfo-4.7.1-4.1
kdevelop4-plugin-python-1.7.1-4.2
kdevelop4-plugin-python-debuginfo-1.7.1-4.2
kdevelop4-plugin-python-debugsource-1.7.1-4.2
kdevelop4-plugins-debugsource-1.7.1-4.2
kdevelop4-plugins-php-1.7.1-4.2
kdevelop4-plugins-php-debuginfo-1.7.1-4.2
kdevelop4-plugins-php-doc-1.7.1-4.2
kdevelop4-plugins-php-doc-debuginfo-1.7.1-4.2
kdevplatform-1.7.1-4.1
kdevplatform-debuginfo-1.7.1-4.1
kdevplatform-debugsource-1.7.1-4.1
libkdevplatform-devel-1.7.1-4.1
libkdevplatform8-1.7.1-4.1
libkdevplatform8-debuginfo-1.7.1-4.1

- openSUSE 13.2 (noarch):

kdevelop4-lang-4.7.1-4.1
kdevelop4-plugin-python-lang-1.7.1-4.2
kdevplatform-lang-1.7.1-4.1


References:



< Previous Next >
This Thread
  • No further messages