Mailinglist Archive: opensuse-updates (101 mails)

< Previous Next >
openSUSE-SU-2015:0184-1: critical: Security update for glibc
openSUSE Security Update: Security update for glibc
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:0184-1
Rating: critical
References: #913646
Cross-References: CVE-2015-0235
Affected Products:
openSUSE 12.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update for glibc fixes the following security issue:

CVE-2015-0235: A vulnerability was found and fixed in the GNU C Library,
specifically in the function gethostbyname(), that could lead to a local
or remote buffer overflow. (bsc#913646)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2015-84

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

glibc-2.17-4.17.1
glibc-debuginfo-2.17-4.17.1
glibc-debugsource-2.17-4.17.1
glibc-devel-2.17-4.17.1
glibc-devel-debuginfo-2.17-4.17.1
glibc-devel-static-2.17-4.17.1
glibc-extra-2.17-4.17.1
glibc-extra-debuginfo-2.17-4.17.1
glibc-locale-2.17-4.17.1
glibc-locale-debuginfo-2.17-4.17.1
glibc-profile-2.17-4.17.1
glibc-utils-2.17-4.17.1
glibc-utils-debuginfo-2.17-4.17.1
glibc-utils-debugsource-2.17-4.17.1
nscd-2.17-4.17.1
nscd-debuginfo-2.17-4.17.1

- openSUSE 12.3 (x86_64):

glibc-utils-32bit-2.17-4.17.1
glibc-utils-debuginfo-32bit-2.17-4.17.1

- openSUSE 12.3 (noarch):

glibc-html-2.17-4.17.1
glibc-i18ndata-2.17-4.17.1
glibc-info-2.17-4.17.1

- openSUSE 12.3 (i586):

glibc-obsolete-2.17-4.17.1
glibc-obsolete-debuginfo-2.17-4.17.1


References:

http://support.novell.com/security/cve/CVE-2015-0235.html
https://bugzilla.suse.com/show_bug.cgi?id=913646


< Previous Next >
This Thread
  • No further messages