Mailinglist Archive: opensuse-updates (89 mails)

< Previous Next >
openSUSE-SU-2015:0007-1: moderate: Security update for ruby2.1
openSUSE Security Update: Security update for ruby2.1
______________________________________________________________________________

Announcement ID: openSUSE-SU-2015:0007-1
Rating: moderate
References: #902851 #905326
Cross-References: CVE-2014-8080 CVE-2014-8090
Affected Products:
openSUSE 13.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


The following issues were fixed in this update:
- CVE-2014-8090: Denial Of Service XML Expansion (bnc#905326)
- CVE-2014-8080: Denial Of Service XML Expansion (bnc#902851)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2015-6

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libruby2_1-2_1-2.1.3-4.1
libruby2_1-2_1-debuginfo-2.1.3-4.1
ruby2.1-2.1.3-4.1
ruby2.1-debuginfo-2.1.3-4.1
ruby2.1-debugsource-2.1.3-4.1
ruby2.1-devel-2.1.3-4.1
ruby2.1-devel-extra-2.1.3-4.1
ruby2.1-doc-2.1.3-4.1
ruby2.1-stdlib-2.1.3-4.1
ruby2.1-stdlib-debuginfo-2.1.3-4.1

- openSUSE 13.2 (noarch):

ruby2.1-doc-ri-2.1.3-4.1


References:

http://support.novell.com/security/cve/CVE-2014-8080.html
http://support.novell.com/security/cve/CVE-2014-8090.html
https://bugzilla.suse.com/show_bug.cgi?id=902851
https://bugzilla.suse.com/show_bug.cgi?id=905326


< Previous Next >
This Thread
  • No further messages