Mailinglist Archive: opensuse-updates (113 mails)

< Previous Next >
openSUSE-SU-2014:1734-1: moderate: update for python
openSUSE Security Update: update for python
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:1734-1
Rating: moderate
References: #863741 #884075 #885882 #898572 #901715
Cross-References: CVE-2014-1912 CVE-2014-4616 CVE-2014-4650
CVE-2014-7185
Affected Products:
openSUSE Evergreen 11.4
______________________________________________________________________________

An update that solves four vulnerabilities and has one
errata is now available.

Description:

This update fixes the following security issues:

bnc#863741 (CVE-2014-1912): Fixed potential buffer overflow in
socket.recvfrom_into bnc#884075 (CVE-2014-4616): Missing boundary check in
JSON module bnc#885882 (CVE-2014-4650): CGIHTTPServer file disclosure and
directory traversal through URL-encoded characters remove link count
optimizations that are incorrect on btrfs (and possibly other filesystems)
bnc#898572 (CVE-2014-7185): potential wraparound/overflow in buffer()
bnc#901715: Disable SSL2 by default


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Evergreen 11.4:

zypper in -t patch 2014-98

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Evergreen 11.4 (i586 x86_64):

libpython2_7-1_0-2.7.3-52.1
libpython2_7-1_0-debuginfo-2.7.3-52.1
python-2.7.3-52.1
python-base-2.7.3-52.1
python-base-debuginfo-2.7.3-52.1
python-base-debugsource-2.7.3-52.1
python-curses-2.7.3-52.1
python-curses-debuginfo-2.7.3-52.1
python-debuginfo-2.7.3-52.1
python-debugsource-2.7.3-52.1
python-demo-2.7.3-52.1
python-devel-2.7.3-52.1
python-gdbm-2.7.3-52.1
python-gdbm-debuginfo-2.7.3-52.1
python-idle-2.7.3-52.1
python-tk-2.7.3-52.1
python-tk-debuginfo-2.7.3-52.1
python-xml-2.7.3-52.1
python-xml-debuginfo-2.7.3-52.1

- openSUSE Evergreen 11.4 (x86_64):

libpython2_7-1_0-32bit-2.7.3-52.1
libpython2_7-1_0-debuginfo-32bit-2.7.3-52.1
python-32bit-2.7.3-52.1
python-base-32bit-2.7.3-52.1
python-base-debuginfo-32bit-2.7.3-52.1
python-debuginfo-32bit-2.7.3-52.1

- openSUSE Evergreen 11.4 (noarch):

python-doc-2.7-52.1
python-doc-pdf-2.7-52.1

- openSUSE Evergreen 11.4 (ia64):

libpython2_7-1_0-debuginfo-x86-2.7.3-52.1
libpython2_7-1_0-x86-2.7.3-52.1
python-base-debuginfo-x86-2.7.3-52.1
python-base-x86-2.7.3-52.1
python-debuginfo-x86-2.7.3-52.1
python-x86-2.7.3-52.1


References:

http://support.novell.com/security/cve/CVE-2014-1912.html
http://support.novell.com/security/cve/CVE-2014-4616.html
http://support.novell.com/security/cve/CVE-2014-4650.html
http://support.novell.com/security/cve/CVE-2014-7185.html
https://bugzilla.suse.com/show_bug.cgi?id=863741
https://bugzilla.suse.com/show_bug.cgi?id=884075
https://bugzilla.suse.com/show_bug.cgi?id=885882
https://bugzilla.suse.com/show_bug.cgi?id=898572
https://bugzilla.suse.com/show_bug.cgi?id=901715


< Previous Next >
This Thread
  • No further messages