Mailinglist Archive: opensuse-updates (113 mails)

< Previous Next >
openSUSE-SU-2014:1656-1: moderate: Security update for seamonkey
openSUSE Security Update: Security update for seamonkey
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:1656-1
Rating: moderate
References: #900639 #908009
Cross-References: CVE-2014-1587 CVE-2014-1588 CVE-2014-1589
CVE-2014-1590 CVE-2014-1591 CVE-2014-1592
CVE-2014-1593 CVE-2014-1594
Affected Products:
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes 8 vulnerabilities is now available.

Description:

seamonkey was updated to version 2.31 to fix eight security issues.

These security issues were fixed:
- Miscellaneous memory safety hazards (CVE-2014-1587, CVE-2014-1588).
- XBL bindings accessible via improper CSS declarations (CVE-2014-1589).
- XMLHttpRequest crashes with some input streams (CVE-2014-1590).
- CSP leaks redirect data via violation reports (CVE-2014-1591).
- Use-after-free during HTML5 parsing (CVE-2014-1592).
- Buffer overflow while parsing media content (CVE-2014-1593).
- Bad casting from the BasicThebesLayer to BasicContainerLayer
(CVE-2014-1594).

This non-security issue was fixed:
- define /usr/share/myspell as additional dictionary location and remove
add-plugins.sh finally (bnc#900639).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-785

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-785

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

seamonkey-2.31-40.2
seamonkey-debuginfo-2.31-40.2
seamonkey-debugsource-2.31-40.2
seamonkey-dom-inspector-2.31-40.2
seamonkey-irc-2.31-40.2
seamonkey-translations-common-2.31-40.2
seamonkey-translations-other-2.31-40.2

- openSUSE 12.3 (i586 x86_64):

seamonkey-2.31-1.65.2
seamonkey-debuginfo-2.31-1.65.2
seamonkey-debugsource-2.31-1.65.2
seamonkey-dom-inspector-2.31-1.65.2
seamonkey-irc-2.31-1.65.2
seamonkey-translations-common-2.31-1.65.2
seamonkey-translations-other-2.31-1.65.2


References:

http://support.novell.com/security/cve/CVE-2014-1587.html
http://support.novell.com/security/cve/CVE-2014-1588.html
http://support.novell.com/security/cve/CVE-2014-1589.html
http://support.novell.com/security/cve/CVE-2014-1590.html
http://support.novell.com/security/cve/CVE-2014-1591.html
http://support.novell.com/security/cve/CVE-2014-1592.html
http://support.novell.com/security/cve/CVE-2014-1593.html
http://support.novell.com/security/cve/CVE-2014-1594.html
https://bugzilla.suse.com/show_bug.cgi?id=900639
https://bugzilla.suse.com/show_bug.cgi?id=908009


< Previous Next >
This Thread
  • No further messages