Mailinglist Archive: opensuse-updates (113 mails)

< Previous Next >
openSUSE-SU-2014:1654-1: moderate: Security update for MozillaThunderbird
openSUSE Security Update: Security update for MozillaThunderbird
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:1654-1
Rating: moderate
References: #900639 #908009
Cross-References: CVE-2014-1587 CVE-2014-1590 CVE-2014-1592
CVE-2014-1593 CVE-2014-1594
Affected Products:
openSUSE 13.2
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available.

Description:

This MozillaThunderbird update fixes several security and non security
issues:

Changes in MozillaThunderbird:
- update to Thunderbird 31.3.0 (bnc#908009)
* MFSA 2014-83/CVE-2014-1587 Miscellaneous memory safety hazards
* MFSA 2014-85/CVE-2014-1590 (bmo#1087633) XMLHttpRequest crashes with
some input streams
* MFSA 2014-87/CVE-2014-1592 (bmo#1088635) Use-after-free during HTML5
parsing
* MFSA 2014-88/CVE-2014-1593 (bmo#1085175) Buffer overflow while parsing
media content
* MFSA 2014-89/CVE-2014-1594 (bmo#1074280) Bad casting from the
BasicThebesLayer to BasicContainerLayer

- fix bashism in mozilla.sh script

- Limit RAM usage during link for ARM

- remove add-plugins.sh and use /usr/share/myspell directly (bnc#900639)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2014-786

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-786

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-786

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

MozillaThunderbird-31.3.0-4.4
MozillaThunderbird-buildsymbols-31.3.0-4.4
MozillaThunderbird-debuginfo-31.3.0-4.4
MozillaThunderbird-debugsource-31.3.0-4.4
MozillaThunderbird-devel-31.3.0-4.4
MozillaThunderbird-translations-common-31.3.0-4.4
MozillaThunderbird-translations-other-31.3.0-4.4

- openSUSE 13.1 (i586 x86_64):

MozillaThunderbird-31.3.0-70.39.3
MozillaThunderbird-buildsymbols-31.3.0-70.39.3
MozillaThunderbird-debuginfo-31.3.0-70.39.3
MozillaThunderbird-debugsource-31.3.0-70.39.3
MozillaThunderbird-devel-31.3.0-70.39.3
MozillaThunderbird-translations-common-31.3.0-70.39.3
MozillaThunderbird-translations-other-31.3.0-70.39.3

- openSUSE 12.3 (i586 x86_64):

MozillaThunderbird-31.3.0-61.67.3
MozillaThunderbird-buildsymbols-31.3.0-61.67.3
MozillaThunderbird-debuginfo-31.3.0-61.67.3
MozillaThunderbird-debugsource-31.3.0-61.67.3
MozillaThunderbird-devel-31.3.0-61.67.3
MozillaThunderbird-translations-common-31.3.0-61.67.3
MozillaThunderbird-translations-other-31.3.0-61.67.3


References:

http://support.novell.com/security/cve/CVE-2014-1587.html
http://support.novell.com/security/cve/CVE-2014-1590.html
http://support.novell.com/security/cve/CVE-2014-1592.html
http://support.novell.com/security/cve/CVE-2014-1593.html
http://support.novell.com/security/cve/CVE-2014-1594.html
https://bugzilla.suse.com/show_bug.cgi?id=900639
https://bugzilla.suse.com/show_bug.cgi?id=908009


< Previous Next >
This Thread
  • No further messages