Mailinglist Archive: opensuse-updates (113 mails)

< Previous Next >
openSUSE-SU-2014:1625-1: moderate: Security update for libyaml
openSUSE Security Update: Security update for libyaml
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:1625-1
Rating: moderate
References: #907809
Cross-References: CVE-2014-9130
Affected Products:
openSUSE 13.2
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This libyaml update fixes the following security issue:

- bnc#907809: assert failure when processing wrapped strings
(CVE-2014-9130)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2014-765

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-765

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-765

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libyaml-0-2-0.1.6-2.4.1
libyaml-0-2-debuginfo-0.1.6-2.4.1
libyaml-debugsource-0.1.6-2.4.1
libyaml-devel-0.1.6-2.4.1

- openSUSE 13.1 (i586 x86_64):

libyaml-0-2-0.1.4-2.16.1
libyaml-0-2-debuginfo-0.1.4-2.16.1
libyaml-debugsource-0.1.4-2.16.1
libyaml-devel-0.1.4-2.16.1

- openSUSE 12.3 (i586 x86_64):

libyaml-0-2-0.1.3-11.16.1
libyaml-0-2-debuginfo-0.1.3-11.16.1
libyaml-debugsource-0.1.3-11.16.1
libyaml-devel-0.1.3-11.16.1


References:

http://support.novell.com/security/cve/CVE-2014-9130.html
https://bugzilla.suse.com/show_bug.cgi?id=907809


< Previous Next >
This Thread
  • No further messages