Mailinglist Archive: opensuse-updates (114 mails)

< Previous Next >
openSUSE-SU-2014:1492-1: moderate: Security update for ImageMagick
openSUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:1492-1
Rating: moderate
References: #905260
Cross-References: CVE-2014-8716
Affected Products:
openSUSE 13.2
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

ImageMagick was updated to fix one security issue.

This security issue was fixed:
- Crafted jpeg file could lead to DOS (CVE-2014-8716).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2014-712

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-712

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-712

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

ImageMagick-6.8.9.8-8.1
ImageMagick-debuginfo-6.8.9.8-8.1
ImageMagick-debugsource-6.8.9.8-8.1
ImageMagick-devel-6.8.9.8-8.1
ImageMagick-extra-6.8.9.8-8.1
ImageMagick-extra-debuginfo-6.8.9.8-8.1
libMagick++-6_Q16-5-6.8.9.8-8.1
libMagick++-6_Q16-5-debuginfo-6.8.9.8-8.1
libMagick++-devel-6.8.9.8-8.1
libMagickCore-6_Q16-2-6.8.9.8-8.1
libMagickCore-6_Q16-2-debuginfo-6.8.9.8-8.1
libMagickWand-6_Q16-2-6.8.9.8-8.1
libMagickWand-6_Q16-2-debuginfo-6.8.9.8-8.1
perl-PerlMagick-6.8.9.8-8.1
perl-PerlMagick-debuginfo-6.8.9.8-8.1

- openSUSE 13.2 (x86_64):

ImageMagick-devel-32bit-6.8.9.8-8.1
libMagick++-6_Q16-5-32bit-6.8.9.8-8.1
libMagick++-6_Q16-5-debuginfo-32bit-6.8.9.8-8.1
libMagick++-devel-32bit-6.8.9.8-8.1
libMagickCore-6_Q16-2-32bit-6.8.9.8-8.1
libMagickCore-6_Q16-2-debuginfo-32bit-6.8.9.8-8.1
libMagickWand-6_Q16-2-32bit-6.8.9.8-8.1
libMagickWand-6_Q16-2-debuginfo-32bit-6.8.9.8-8.1

- openSUSE 13.2 (noarch):

ImageMagick-doc-6.8.9.8-8.1

- openSUSE 13.1 (i586 x86_64):

ImageMagick-6.8.6.9-2.28.1
ImageMagick-debuginfo-6.8.6.9-2.28.1
ImageMagick-debugsource-6.8.6.9-2.28.1
ImageMagick-devel-6.8.6.9-2.28.1
ImageMagick-extra-6.8.6.9-2.28.1
ImageMagick-extra-debuginfo-6.8.6.9-2.28.1
libMagick++-6_Q16-2-6.8.6.9-2.28.1
libMagick++-6_Q16-2-debuginfo-6.8.6.9-2.28.1
libMagick++-devel-6.8.6.9-2.28.1
libMagickCore-6_Q16-1-6.8.6.9-2.28.1
libMagickCore-6_Q16-1-debuginfo-6.8.6.9-2.28.1
libMagickWand-6_Q16-1-6.8.6.9-2.28.1
libMagickWand-6_Q16-1-debuginfo-6.8.6.9-2.28.1
perl-PerlMagick-6.8.6.9-2.28.1
perl-PerlMagick-debuginfo-6.8.6.9-2.28.1

- openSUSE 13.1 (x86_64):

ImageMagick-devel-32bit-6.8.6.9-2.28.1
libMagick++-6_Q16-2-32bit-6.8.6.9-2.28.1
libMagick++-6_Q16-2-debuginfo-32bit-6.8.6.9-2.28.1
libMagick++-devel-32bit-6.8.6.9-2.28.1
libMagickCore-6_Q16-1-32bit-6.8.6.9-2.28.1
libMagickCore-6_Q16-1-debuginfo-32bit-6.8.6.9-2.28.1
libMagickWand-6_Q16-1-32bit-6.8.6.9-2.28.1
libMagickWand-6_Q16-1-debuginfo-32bit-6.8.6.9-2.28.1

- openSUSE 13.1 (noarch):

ImageMagick-doc-6.8.6.9-2.28.1

- openSUSE 12.3 (i586 x86_64):

ImageMagick-6.7.8.8-4.21.1
ImageMagick-debuginfo-6.7.8.8-4.21.1
ImageMagick-debugsource-6.7.8.8-4.21.1
ImageMagick-devel-6.7.8.8-4.21.1
ImageMagick-extra-6.7.8.8-4.21.1
ImageMagick-extra-debuginfo-6.7.8.8-4.21.1
libMagick++-devel-6.7.8.8-4.21.1
libMagick++5-6.7.8.8-4.21.1
libMagick++5-debuginfo-6.7.8.8-4.21.1
libMagickCore5-6.7.8.8-4.21.1
libMagickCore5-debuginfo-6.7.8.8-4.21.1
libMagickWand5-6.7.8.8-4.21.1
libMagickWand5-debuginfo-6.7.8.8-4.21.1
perl-PerlMagick-6.7.8.8-4.21.1
perl-PerlMagick-debuginfo-6.7.8.8-4.21.1

- openSUSE 12.3 (x86_64):

ImageMagick-devel-32bit-6.7.8.8-4.21.1
libMagickCore5-32bit-6.7.8.8-4.21.1
libMagickCore5-debuginfo-32bit-6.7.8.8-4.21.1
libMagickWand5-32bit-6.7.8.8-4.21.1
libMagickWand5-debuginfo-32bit-6.7.8.8-4.21.1

- openSUSE 12.3 (noarch):

ImageMagick-doc-6.7.8.8-4.21.1


References:

http://support.novell.com/security/cve/CVE-2014-8716.html
https://bugzilla.suse.com/show_bug.cgi?id=905260


< Previous Next >
This Thread
  • No further messages