Mailinglist Archive: opensuse-updates (114 mails)

< Previous Next >
openSUSE-SU-2014:1460-1: moderate: Security update for emacs
openSUSE Security Update: Security update for emacs
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:1460-1
Rating: moderate
References: #876847
Cross-References: CVE-2014-3421 CVE-2014-3422 CVE-2014-3423
CVE-2014-3424
Affected Products:
openSUSE 13.1
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

emacs was updated to fix four security issues.

These security issues were fixed:
- Avoid unsecure usage of temporary files (CVE-2014-3421).
- Avoid unsecure usage of temporary files (CVE-2014-3422).
- Avoid unsecure usage of temporary files (CVE-2014-3423).
- Avoid unsecure usage of temporary files (CVE-2014-3424).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-692

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

emacs-24.3-6.14.2
emacs-debuginfo-24.3-6.14.2
emacs-debugsource-24.3-6.14.2
emacs-nox-24.3-6.14.2
emacs-nox-debuginfo-24.3-6.14.2
emacs-x11-24.3-6.14.2
emacs-x11-debuginfo-24.3-6.14.2
etags-24.3-6.14.2
etags-debuginfo-24.3-6.14.2

- openSUSE 13.1 (noarch):

emacs-el-24.3-6.14.2
emacs-info-24.3-6.14.2


References:

http://support.novell.com/security/cve/CVE-2014-3421.html
http://support.novell.com/security/cve/CVE-2014-3422.html
http://support.novell.com/security/cve/CVE-2014-3423.html
http://support.novell.com/security/cve/CVE-2014-3424.html
https://bugzilla.suse.com/show_bug.cgi?id=876847


< Previous Next >
This Thread
  • No further messages