Mailinglist Archive: opensuse-updates (114 mails)

< Previous Next >
openSUSE-SU-2014:1396-1: moderate: Security update for ImageMagick
openSUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:1396-1
Rating: moderate
References: #903204 #903216 #903638
Cross-References: CVE-2014-8354 CVE-2014-8355 CVE-2014-8562

Affected Products:
openSUSE 13.2
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

ImageMagick was updated to fix three security issues.

These security issues were fixed:
- Out-of-bounds memory access in PCX parser (CVE-2014-8355).
- Out-of-bounds memory access in resize code (CVE-2014-8354).
- Out-of-bounds memory error in DCM decode (CVE-2014-8562).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2014-649

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-649

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-649

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

ImageMagick-6.8.9.8-4.1
ImageMagick-debuginfo-6.8.9.8-4.1
ImageMagick-debugsource-6.8.9.8-4.1
ImageMagick-devel-6.8.9.8-4.1
ImageMagick-extra-6.8.9.8-4.1
ImageMagick-extra-debuginfo-6.8.9.8-4.1
libMagick++-6_Q16-5-6.8.9.8-4.1
libMagick++-6_Q16-5-debuginfo-6.8.9.8-4.1
libMagick++-devel-6.8.9.8-4.1
libMagickCore-6_Q16-2-6.8.9.8-4.1
libMagickCore-6_Q16-2-debuginfo-6.8.9.8-4.1
libMagickWand-6_Q16-2-6.8.9.8-4.1
libMagickWand-6_Q16-2-debuginfo-6.8.9.8-4.1
perl-PerlMagick-6.8.9.8-4.1
perl-PerlMagick-debuginfo-6.8.9.8-4.1

- openSUSE 13.2 (x86_64):

ImageMagick-devel-32bit-6.8.9.8-4.1
libMagick++-6_Q16-5-32bit-6.8.9.8-4.1
libMagick++-6_Q16-5-debuginfo-32bit-6.8.9.8-4.1
libMagick++-devel-32bit-6.8.9.8-4.1
libMagickCore-6_Q16-2-32bit-6.8.9.8-4.1
libMagickCore-6_Q16-2-debuginfo-32bit-6.8.9.8-4.1
libMagickWand-6_Q16-2-32bit-6.8.9.8-4.1
libMagickWand-6_Q16-2-debuginfo-32bit-6.8.9.8-4.1

- openSUSE 13.2 (noarch):

ImageMagick-doc-6.8.9.8-4.1

- openSUSE 13.1 (i586 x86_64):

ImageMagick-6.8.6.9-2.24.1
ImageMagick-debuginfo-6.8.6.9-2.24.1
ImageMagick-debugsource-6.8.6.9-2.24.1
ImageMagick-devel-6.8.6.9-2.24.1
ImageMagick-extra-6.8.6.9-2.24.1
ImageMagick-extra-debuginfo-6.8.6.9-2.24.1
libMagick++-6_Q16-2-6.8.6.9-2.24.1
libMagick++-6_Q16-2-debuginfo-6.8.6.9-2.24.1
libMagick++-devel-6.8.6.9-2.24.1
libMagickCore-6_Q16-1-6.8.6.9-2.24.1
libMagickCore-6_Q16-1-debuginfo-6.8.6.9-2.24.1
libMagickWand-6_Q16-1-6.8.6.9-2.24.1
libMagickWand-6_Q16-1-debuginfo-6.8.6.9-2.24.1
perl-PerlMagick-6.8.6.9-2.24.1
perl-PerlMagick-debuginfo-6.8.6.9-2.24.1

- openSUSE 13.1 (x86_64):

ImageMagick-devel-32bit-6.8.6.9-2.24.1
libMagick++-6_Q16-2-32bit-6.8.6.9-2.24.1
libMagick++-6_Q16-2-debuginfo-32bit-6.8.6.9-2.24.1
libMagick++-devel-32bit-6.8.6.9-2.24.1
libMagickCore-6_Q16-1-32bit-6.8.6.9-2.24.1
libMagickCore-6_Q16-1-debuginfo-32bit-6.8.6.9-2.24.1
libMagickWand-6_Q16-1-32bit-6.8.6.9-2.24.1
libMagickWand-6_Q16-1-debuginfo-32bit-6.8.6.9-2.24.1

- openSUSE 13.1 (noarch):

ImageMagick-doc-6.8.6.9-2.24.1

- openSUSE 12.3 (i586 x86_64):

ImageMagick-6.7.8.8-4.17.1
ImageMagick-debuginfo-6.7.8.8-4.17.1
ImageMagick-debugsource-6.7.8.8-4.17.1
ImageMagick-devel-6.7.8.8-4.17.1
ImageMagick-extra-6.7.8.8-4.17.1
ImageMagick-extra-debuginfo-6.7.8.8-4.17.1
libMagick++-devel-6.7.8.8-4.17.1
libMagick++5-6.7.8.8-4.17.1
libMagick++5-debuginfo-6.7.8.8-4.17.1
libMagickCore5-6.7.8.8-4.17.1
libMagickCore5-debuginfo-6.7.8.8-4.17.1
libMagickWand5-6.7.8.8-4.17.1
libMagickWand5-debuginfo-6.7.8.8-4.17.1
perl-PerlMagick-6.7.8.8-4.17.1
perl-PerlMagick-debuginfo-6.7.8.8-4.17.1

- openSUSE 12.3 (x86_64):

ImageMagick-devel-32bit-6.7.8.8-4.17.1
libMagickCore5-32bit-6.7.8.8-4.17.1
libMagickCore5-debuginfo-32bit-6.7.8.8-4.17.1
libMagickWand5-32bit-6.7.8.8-4.17.1
libMagickWand5-debuginfo-32bit-6.7.8.8-4.17.1

- openSUSE 12.3 (noarch):

ImageMagick-doc-6.7.8.8-4.17.1


References:

http://support.novell.com/security/cve/CVE-2014-8354.html
http://support.novell.com/security/cve/CVE-2014-8355.html
http://support.novell.com/security/cve/CVE-2014-8562.html
https://bugzilla.suse.com/show_bug.cgi?id=903204
https://bugzilla.suse.com/show_bug.cgi?id=903216
https://bugzilla.suse.com/show_bug.cgi?id=903638


< Previous Next >
This Thread
  • No further messages