Mailinglist Archive: opensuse-updates (114 mails)

< Previous Next >
openSUSE-SU-2014:1395-1: moderate: libserf: Disable SSLv2 and SSLv3.
openSUSE Security Update: libserf: Disable SSLv2 and SSLv3.
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:1395-1
Rating: moderate
References:
Cross-References: CVE-2014-3566
Affected Products:
openSUSE 13.2
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

libserf was updated to disable SSLv2 and SSLv3.

libserf was updated to version 1.3.8 on openSUSE 13.1 and 13.2. This
release also fixes a problem with handling very large gzip-encoded HTTP
responses.

For openSUSE 12.3 libserf 1.1.1 was patched to disable SSLv2 and SSLv3.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.2:

zypper in -t patch openSUSE-2014-647

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-647

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-647

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.2 (i586 x86_64):

libserf-1-1-1.3.8-2.4.1
libserf-1-1-debuginfo-1.3.8-2.4.1
libserf-debugsource-1.3.8-2.4.1
libserf-devel-1.3.8-2.4.1

- openSUSE 13.1 (i586 x86_64):

libserf-1-1-1.3.8-20.1
libserf-1-1-debuginfo-1.3.8-20.1
libserf-debugsource-1.3.8-20.1
libserf-devel-1.3.8-20.1

- openSUSE 12.3 (i586 x86_64):

libserf-1-0-1.1.1-2.8.1
libserf-1-0-debuginfo-1.1.1-2.8.1
libserf-debugsource-1.1.1-2.8.1
libserf-devel-1.1.1-2.8.1


References:

http://support.novell.com/security/cve/CVE-2014-3566.html


< Previous Next >
This Thread
  • No further messages