Mailinglist Archive: opensuse-updates (64 mails)

< Previous Next >
openSUSE-SU-2014:1135-1: moderate: ppp: fixed integer overflow in option parsing
openSUSE Security Update: ppp: fixed integer overflow in option parsing
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:1135-1
Rating: moderate
References: #891489
Cross-References: CVE-2014-3158
Affected Products:
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

ppp was updated to fix an integer overflow in option parsing.
(CVE-2014-3158, bnc#891489).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-545

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-545

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

ppp-2.4.5-20.4.1
ppp-debuginfo-2.4.5-20.4.1
ppp-debugsource-2.4.5-20.4.1
ppp-devel-2.4.5-20.4.1

- openSUSE 12.3 (i586 x86_64):

ppp-2.4.5-15.4.1
ppp-debuginfo-2.4.5-15.4.1
ppp-debugsource-2.4.5-15.4.1
ppp-devel-2.4.5-15.4.1


References:

http://support.novell.com/security/cve/CVE-2014-3158.html
https://bugzilla.novell.com/891489


< Previous Next >
This Thread
  • No further messages