Mailinglist Archive: opensuse-updates (48 mails)

< Previous Next >
openSUSE-SU-2014:1060-1: moderate: update for IPython
openSUSE Security Update: update for IPython
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:1060-1
Rating: moderate
References: #887577
Cross-References: CVE-2014-3429
Affected Products:
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This IPython update fixes the following security issue:

- RCE in IPython Notebook via cross-origin websocket connection
(CVE-2014-3429, bnc#887577)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-513

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-513

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

python-pyzmq-13.0.0-4.4.1
python-pyzmq-debuginfo-13.0.0-4.4.1
python-pyzmq-debugsource-13.0.0-4.4.1
python-pyzmq-devel-13.0.0-4.4.1

- openSUSE 13.1 (noarch):

IPython-0.13.1-4.4.1
IPython-1.0.0-2.4.3
IPython-doc-0.13.1-4.4.1
IPython-doc-1.0.0-2.4.3

- openSUSE 12.3 (noarch):

IPython-0.13.1-4.4.1
IPython-doc-0.13.1-4.4.1
python3-IPython-0.13.1-4.4.1


References:

http://support.novell.com/security/cve/CVE-2014-3429.html
https://bugzilla.novell.com/887577


< Previous Next >
This Thread
  • No further messages