Mailinglist Archive: opensuse-updates (86 mails)

< Previous Next >
openSUSE-SU-2014:0722-1: moderate: update for libgadu
openSUSE Security Update: update for libgadu
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:0722-1
Rating: moderate
References: #878540
Cross-References: CVE-2013-6487 CVE-2014-3775
Affected Products:
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


- Update to version 1.11.4, bugfix release:
+ Fix buffer overflow with remote code execution potential. Only
triggerable by a Gadu-Gadu server or a man-in-the-middle.
CVE-2013-6487 (bnc#861019, bnc#878540)
+ Fix memory overwrite in file transfer with proxy server. CVE-2014-3775
(bnc#878540)
+ Minor fixes reported by Pidgin project members.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-400

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-400

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

libgadu-debugsource-1.11.4-4.4.1
libgadu-devel-1.11.4-4.4.1
libgadu3-1.11.4-4.4.1
libgadu3-debuginfo-1.11.4-4.4.1

- openSUSE 12.3 (i586 x86_64):

libgadu-debugsource-1.11.4-2.4.1
libgadu-devel-1.11.4-2.4.1
libgadu3-1.11.4-2.4.1
libgadu3-debuginfo-1.11.4-2.4.1


References:

http://support.novell.com/security/cve/CVE-2013-6487.html
http://support.novell.com/security/cve/CVE-2014-3775.html
https://bugzilla.novell.com/878540


< Previous Next >
This Thread
  • No further messages