Mailinglist Archive: opensuse-updates (68 mails)

< Previous Next >
openSUSE-SU-2014:0499-1: moderate: a2ps: fixed commandinjection in fixps
openSUSE Security Update: a2ps: fixed commandinjection in fixps
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:0499-1
Rating: moderate
References: #871097
Cross-References: CVE-2014-0466
Affected Products:
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

a2ps was updated to fix a security issue:

fixps called ghostscript without -dSAFER, enabling
postscript files processed by fixps to execute code on the
system. (CVE-2014-0466)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-279

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-279

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

a2ps-4.13-1356.4.1
a2ps-debuginfo-4.13-1356.4.1
a2ps-debugsource-4.13-1356.4.1
a2ps-devel-4.13-1356.4.1

- openSUSE 12.3 (i586 x86_64):

a2ps-4.13-1353.4.1
a2ps-debuginfo-4.13-1353.4.1
a2ps-debugsource-4.13-1353.4.1
a2ps-devel-4.13-1353.4.1


References:

http://support.novell.com/security/cve/CVE-2014-0466.html
https://bugzilla.novell.com/871097


< Previous Next >
This Thread
  • No further messages