Mailinglist Archive: opensuse-updates (130 mails)

< Previous Next >
openSUSE-SU-2013:1931-1: moderate: update for rubygem-activesupport-3_2
openSUSE Security Update: update for rubygem-activesupport-3_2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:1931-1
Rating: moderate
References: #846239
Cross-References: CVE-2013-4389
Affected Products:
openSUSE 13.1
openSUSE 12.3
openSUSE 12.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update fixes the following security issues with
rubygem-activesupport-3_2:

- fix CVE-2013-4389: rubygem-actionmailer-3_1: possible
DoS vulnerability in the log subscriber component
(bnc#846239) File CVE-2013-4389.patch contains the fix.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2013-1003

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-1003

- openSUSE 12.2:

zypper in -t patch openSUSE-2013-1003

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

rubygem-activesupport-3_2-3.2.13-3.4.1
rubygem-activesupport-3_2-doc-3.2.13-3.4.1

- openSUSE 12.3 (i586 x86_64):

rubygem-activesupport-3_2-3.2.12-1.4.1
rubygem-activesupport-3_2-doc-3.2.12-1.4.1

- openSUSE 12.2 (i586 x86_64):

rubygem-activesupport-3_2-3.2.12-2.17.1
rubygem-activesupport-3_2-doc-3.2.12-2.17.1


References:

http://support.novell.com/security/cve/CVE-2013-4389.html
https://bugzilla.novell.com/846239


< Previous Next >
This Thread
  • No further messages