Mailinglist Archive: opensuse-updates (120 mails)

< Previous Next >
openSUSE-SU-2013:1644-1: - update to SeaMonkey 2.22 (bnc#847708)
openSUSE Security Update: - update to SeaMonkey 2.22 (bnc#847708)
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:1644-1
Rating: low
References: #847708
Cross-References: CVE-2013-5590 CVE-2013-5591 CVE-2013-5592
CVE-2013-5593 CVE-2013-5595 CVE-2013-5596
CVE-2013-5597 CVE-2013-5598 CVE-2013-5599
CVE-2013-5600 CVE-2013-5601 CVE-2013-5602
CVE-2013-5603 CVE-2013-5604
Affected Products:
openSUSE 12.2
______________________________________________________________________________

An update that fixes 14 vulnerabilities is now available.

Description:

- update to SeaMonkey 2.22 (bnc#847708)
* rebased patches
* requires NSS 3.15.2 or higher
* MFSA 2013-93/CVE-2013-5590/CVE-2013-5591/CVE-2013-5592
Miscellaneous memory safety hazards
* MFSA 2013-94/CVE-2013-5593 (bmo#868327) Spoofing
addressbar through SELECT element
* MFSA 2013-95/CVE-2013-5604 (bmo#914017) Access
violation with XSLT and uninitialized data
* MFSA 2013-96/CVE-2013-5595 (bmo#916580) Improperly
initialized memory and overflows in some JavaScript
functions
* MFSA 2013-97/CVE-2013-5596 (bmo#910881) Writing to
cycle collected object during image decoding
* MFSA 2013-98/CVE-2013-5597 (bmo#918864) Use-after-free
when updating offline cache
* MFSA 2013-99/CVE-2013-5598 (bmo#920515) Security bypass
of PDF.js checks using iframes
* MFSA 2013-100/CVE-2013-5599/CVE-2013-5600/CVE-2013-5601
(bmo#915210, bmo#915576, bmo#916685) Miscellaneous
use-after-free issues found through ASAN fuzzing
* MFSA 2013-101/CVE-2013-5602 (bmo#897678) Memory
corruption in workers
* MFSA 2013-102/CVE-2013-5603 (bmo#916404) Use-after-free
in HTML document templates


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.2:

zypper in -t patch openSUSE-2013-824

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.2 (i586 x86_64):

seamonkey-2.22-2.54.1
seamonkey-debuginfo-2.22-2.54.1
seamonkey-debugsource-2.22-2.54.1
seamonkey-dom-inspector-2.22-2.54.1
seamonkey-irc-2.22-2.54.1
seamonkey-translations-common-2.22-2.54.1
seamonkey-translations-other-2.22-2.54.1
seamonkey-venkman-2.22-2.54.1


References:

http://support.novell.com/security/cve/CVE-2013-5590.html
http://support.novell.com/security/cve/CVE-2013-5591.html
http://support.novell.com/security/cve/CVE-2013-5592.html
http://support.novell.com/security/cve/CVE-2013-5593.html
http://support.novell.com/security/cve/CVE-2013-5595.html
http://support.novell.com/security/cve/CVE-2013-5596.html
http://support.novell.com/security/cve/CVE-2013-5597.html
http://support.novell.com/security/cve/CVE-2013-5598.html
http://support.novell.com/security/cve/CVE-2013-5599.html
http://support.novell.com/security/cve/CVE-2013-5600.html
http://support.novell.com/security/cve/CVE-2013-5601.html
http://support.novell.com/security/cve/CVE-2013-5602.html
http://support.novell.com/security/cve/CVE-2013-5603.html
http://support.novell.com/security/cve/CVE-2013-5604.html
https://bugzilla.novell.com/847708


< Previous Next >
This Thread
  • No further messages