Mailinglist Archive: opensuse-updates (96 mails)

< Previous Next >
openSUSE-SU-2013:1201-1: moderate: tinyproxy: security fixes
openSUSE Security Update: tinyproxy: security fixes
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:1201-1
Rating: moderate
References: #776506
Cross-References: CVE-2012-3505
Affected Products:
openSUSE 12.3
openSUSE 12.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


Tinyproxy allowed remote attackers to cause a denial of
service (CPU and memory consumption) via (1) a large number
of headers or (2) a large number of forged headers that
trigger hash collisions predictably. bucket.

This update fixes this by limiting headers and improving
the hash keying.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-587

- openSUSE 12.2:

zypper in -t patch openSUSE-2013-587

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

tinyproxy-1.8.3-4.4.1
tinyproxy-debuginfo-1.8.3-4.4.1
tinyproxy-debugsource-1.8.3-4.4.1

- openSUSE 12.2 (i586 x86_64):

tinyproxy-1.8.3-2.4.1
tinyproxy-debuginfo-1.8.3-2.4.1
tinyproxy-debugsource-1.8.3-2.4.1


References:

http://support.novell.com/security/cve/CVE-2012-3505.html
https://bugzilla.novell.com/776506


< Previous Next >
This Thread
  • No further messages