Mailinglist Archive: opensuse-updates (200 mails)

< Previous Next >
openSUSE-SU-2013:1031-1: moderate: update for libXcursor
openSUSE Security Update: update for libXcursor
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:1031-1
Rating: moderate
References: #815451 #821663
Cross-References: CVE-2013-2003
Affected Products:
openSUSE 12.3
openSUSE 12.2
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update of libXcursor fixes an integer overflow issue.
-
U_0001-signedness-bug-integer-overflow-in-_XcursorFileHeade.
patch
* signedness bug & integer overflow in
_XcursorFileHeaderCreate() [CVE-2013-2003] (bnc#821663,
bnc#815451)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-502

- openSUSE 12.2:

zypper in -t patch openSUSE-2013-502

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

libXcursor-debugsource-1.1.13-4.4.1
libXcursor-devel-1.1.13-4.4.1
libXcursor1-1.1.13-4.4.1
libXcursor1-debuginfo-1.1.13-4.4.1

- openSUSE 12.3 (x86_64):

libXcursor-devel-32bit-1.1.13-4.4.1
libXcursor1-32bit-1.1.13-4.4.1
libXcursor1-debuginfo-32bit-1.1.13-4.4.1

- openSUSE 12.2 (i586 x86_64):

libXcursor-debugsource-1.1.13-2.4.1
libXcursor-devel-1.1.13-2.4.1
libXcursor1-1.1.13-2.4.1
libXcursor1-debuginfo-1.1.13-2.4.1

- openSUSE 12.2 (x86_64):

libXcursor-devel-32bit-1.1.13-2.4.1
libXcursor1-32bit-1.1.13-2.4.1
libXcursor1-debuginfo-32bit-1.1.13-2.4.1


References:

http://support.novell.com/security/cve/CVE-2013-2003.html
https://bugzilla.novell.com/815451
https://bugzilla.novell.com/821663


< Previous Next >
This Thread
  • No further messages