Mailinglist Archive: opensuse-updates (111 mails)

< Previous Next >
openSUSE-SU-2013:0629-1: moderate: apache2: security and bugfixes
openSUSE Security Update: apache2: security and bugfixes
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:0629-1
Rating: moderate
References: #777260 #798733 #806458 #807152
Cross-References: CVE-2012-2687 CVE-2012-3499 CVE-2012-4558

Affected Products:
openSUSE 12.3
openSUSE 12.2
openSUSE 12.1
______________________________________________________________________________

An update that solves three vulnerabilities and has one
errata is now available.

Description:


apache2 was updated to fix:

- fix for cross site scripting vulnerability in
mod_balancer. This is CVE-2012-4558 [bnc#807152]
- fixes for low profile cross site scripting
vulnerabilities, known as CVE-2012-3499 [bnc#806458]

- Escape filename for the case that uploads are allowed
with untrusted user's control over filenames and
mod_negotiation enabled on the same directory.
CVE-2012-2687 [bnc#777260]

And also these bugs:
- httpd-2.2.x-bnc798733-SNI_ignorecase.diff: ignore case
when checking against SNI server names. [bnc#798733]


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-308

- openSUSE 12.2:

zypper in -t patch openSUSE-2013-308

- openSUSE 12.1:

zypper in -t patch openSUSE-2013-308

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

apache2-2.2.22-10.4.1
apache2-debuginfo-2.2.22-10.4.1
apache2-debugsource-2.2.22-10.4.1
apache2-devel-2.2.22-10.4.1
apache2-event-2.2.22-10.4.1
apache2-event-debuginfo-2.2.22-10.4.1
apache2-example-pages-2.2.22-10.4.1
apache2-itk-2.2.22-10.4.1
apache2-itk-debuginfo-2.2.22-10.4.1
apache2-prefork-2.2.22-10.4.1
apache2-prefork-debuginfo-2.2.22-10.4.1
apache2-utils-2.2.22-10.4.1
apache2-utils-debuginfo-2.2.22-10.4.1
apache2-worker-2.2.22-10.4.1
apache2-worker-debuginfo-2.2.22-10.4.1

- openSUSE 12.3 (noarch):

apache2-doc-2.2.22-10.4.1

- openSUSE 12.2 (i586 x86_64):

apache2-2.2.22-4.14.1
apache2-debuginfo-2.2.22-4.14.1
apache2-debugsource-2.2.22-4.14.1
apache2-devel-2.2.22-4.14.1
apache2-event-2.2.22-4.14.1
apache2-event-debuginfo-2.2.22-4.14.1
apache2-example-pages-2.2.22-4.14.1
apache2-itk-2.2.22-4.14.1
apache2-itk-debuginfo-2.2.22-4.14.1
apache2-prefork-2.2.22-4.14.1
apache2-prefork-debuginfo-2.2.22-4.14.1
apache2-utils-2.2.22-4.14.1
apache2-utils-debuginfo-2.2.22-4.14.1
apache2-worker-2.2.22-4.14.1
apache2-worker-debuginfo-2.2.22-4.14.1

- openSUSE 12.2 (noarch):

apache2-doc-2.2.22-4.14.1

- openSUSE 12.1 (i586 x86_64):

apache2-2.2.21-3.13.1
apache2-debuginfo-2.2.21-3.13.1
apache2-debugsource-2.2.21-3.13.1
apache2-devel-2.2.21-3.13.1
apache2-event-2.2.21-3.13.1
apache2-event-debuginfo-2.2.21-3.13.1
apache2-example-pages-2.2.21-3.13.1
apache2-itk-2.2.21-3.13.1
apache2-itk-debuginfo-2.2.21-3.13.1
apache2-prefork-2.2.21-3.13.1
apache2-prefork-debuginfo-2.2.21-3.13.1
apache2-utils-2.2.21-3.13.1
apache2-utils-debuginfo-2.2.21-3.13.1
apache2-worker-2.2.21-3.13.1
apache2-worker-debuginfo-2.2.21-3.13.1

- openSUSE 12.1 (noarch):

apache2-doc-2.2.21-3.13.1


References:

http://support.novell.com/security/cve/CVE-2012-2687.html
http://support.novell.com/security/cve/CVE-2012-3499.html
http://support.novell.com/security/cve/CVE-2012-4558.html
https://bugzilla.novell.com/777260
https://bugzilla.novell.com/798733
https://bugzilla.novell.com/806458
https://bugzilla.novell.com/807152


< Previous Next >
This Thread
  • No further messages