Mailinglist Archive: opensuse-updates (50 mails)

< Previous Next >
openSUSE-SU-2012:1069-1: nut: fixed a denial of service
openSUSE Security Update: nut: fixed a denial of service
______________________________________________________________________________

Announcement ID: openSUSE-SU-2012:1069-1
Rating: low
References: #764699
Cross-References: CVE-2012-2944
Affected Products:
openSUSE 12.2
openSUSE 12.1
openSUSE 11.4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

The nut upsd is prone to multiple flaws that allow remote
attackers to cause a denial of service (application crash)
by sending unexpected data.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.2:

zypper in -t patch openSUSE-2012-539

- openSUSE 12.1:

zypper in -t patch openSUSE-2012-539

- openSUSE 11.4:

zypper in -t patch openSUSE-2012-539

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.2 (i586 x86_64):

libupsclient1-2.6.3-2.4.3
libupsclient1-debuginfo-2.6.3-2.4.3
nut-2.6.3-2.4.3
nut-cgi-2.6.3-2.4.3
nut-cgi-debuginfo-2.6.3-2.4.3
nut-debuginfo-2.6.3-2.4.3
nut-debugsource-2.6.3-2.4.3
nut-devel-2.6.3-2.4.3
nut-drivers-net-2.6.3-2.4.3
nut-drivers-net-debuginfo-2.6.3-2.4.3

- openSUSE 12.1 (i586 x86_64):

libupsclient1-2.6.1-3.4.1
libupsclient1-debuginfo-2.6.1-3.4.1
nut-2.6.1-3.4.1
nut-cgi-2.6.1-3.4.1
nut-cgi-debuginfo-2.6.1-3.4.1
nut-debuginfo-2.6.1-3.4.1
nut-debugsource-2.6.1-3.4.1
nut-devel-2.6.1-3.4.1
nut-drivers-net-2.6.1-3.4.1
nut-drivers-net-debuginfo-2.6.1-3.4.1

- openSUSE 11.4 (i586 x86_64):

libupsclient1-2.6.0-4.11.1
libupsclient1-debuginfo-2.6.0-4.11.1
nut-2.6.0-4.11.1
nut-cgi-2.6.0-4.11.1
nut-cgi-debuginfo-2.6.0-4.11.1
nut-classic-2.6.0-4.11.1
nut-classic-debuginfo-2.6.0-4.11.1
nut-debuginfo-2.6.0-4.11.1
nut-debugsource-2.6.0-4.11.1
nut-devel-2.6.0-4.11.1
nut-drivers-net-2.6.0-4.11.1
nut-drivers-net-debuginfo-2.6.0-4.11.1
nut-hal-2.6.0-4.11.1
nut-hal-debuginfo-2.6.0-4.11.1


References:

http://support.novell.com/security/cve/CVE-2012-2944.html
https://bugzilla.novell.com/764699


< Previous Next >
List Navigation
This Thread
  • No further messages