Mailinglist Archive: opensuse-updates (56 mails)

< Previous Next >
openSUSE-SU-2012:0915-1: moderate: arpwatch (CVE-2012-2653)
openSUSE Security Update: arpwatch (CVE-2012-2653)
______________________________________________________________________________

Announcement ID: openSUSE-SU-2012:0915-1
Rating: moderate
References: #764521
Cross-References: CVE-2012-2653
Affected Products:
openSUSE 12.1
openSUSE 11.4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:



Changes in arpwatch:

- arpwatch-2.1a11-drop-privs.dif: call initgroups() with
pw->pw_gid, not NULL, to not have groupid 0 initialized.
(bnc#764521, CVE-2012-2653)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.1:

zypper in -t patch openSUSE-2012-439

- openSUSE 11.4:

zypper in -t patch openSUSE-2012-439

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.1 (i586 x86_64):

arpwatch-2.1a15-144.4.1
arpwatch-debuginfo-2.1a15-144.4.1
arpwatch-debugsource-2.1a15-144.4.1
arpwatch-ethercodes-build-2.1a15-144.4.1

- openSUSE 11.4 (i586 x86_64):

arpwatch-2.1a15-143.1
arpwatch-debuginfo-2.1a15-143.1
arpwatch-debugsource-2.1a15-143.1
arpwatch-ethercodes-build-2.1a15-143.1


References:

http://support.novell.com/security/cve/CVE-2012-2653.html
https://bugzilla.novell.com/764521


< Previous Next >
This Thread
  • No further messages