Mailinglist Archive: opensuse-updates (33 mails)

< Previous Next >
openSUSE-SU-2012:0691-1: important: update for strongswan
openSUSE Security Update: update for strongswan
______________________________________________________________________________

Announcement ID: openSUSE-SU-2012:0691-1
Rating: important
References: #761325
Cross-References: CVE-2012-2388
Affected Products:
openSUSE 12.1
openSUSE 11.4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

Strongswan's gmp plugin could treat empty RSA signature as
valid ones


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.1:

zypper in -t patch openSUSE-2012-309

- openSUSE 11.4:

zypper in -t patch openSUSE-2012-309

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.1 (i586 x86_64):

strongswan-4.5.3-5.4.1
strongswan-debugsource-4.5.3-5.4.1
strongswan-doc-4.5.3-5.4.1
strongswan-ikev1-4.5.3-5.4.1
strongswan-ikev1-debuginfo-4.5.3-5.4.1
strongswan-ikev2-4.5.3-5.4.1
strongswan-ikev2-debuginfo-4.5.3-5.4.1
strongswan-ipsec-4.5.3-5.4.1
strongswan-ipsec-debuginfo-4.5.3-5.4.1
strongswan-libs0-4.5.3-5.4.1
strongswan-libs0-debuginfo-4.5.3-5.4.1
strongswan-mysql-4.5.3-5.4.1
strongswan-mysql-debuginfo-4.5.3-5.4.1
strongswan-nm-4.5.3-5.4.1
strongswan-nm-debuginfo-4.5.3-5.4.1
strongswan-sqlite-4.5.3-5.4.1
strongswan-sqlite-debuginfo-4.5.3-5.4.1

- openSUSE 11.4 (i586 x86_64):

strongswan-4.5.0-6.45.1
strongswan-debugsource-4.5.0-6.45.1
strongswan-doc-4.5.0-6.45.1
strongswan-ikev1-4.5.0-6.45.1
strongswan-ikev1-debuginfo-4.5.0-6.45.1
strongswan-ikev2-4.5.0-6.45.1
strongswan-ikev2-debuginfo-4.5.0-6.45.1
strongswan-ipsec-4.5.0-6.45.1
strongswan-ipsec-debuginfo-4.5.0-6.45.1
strongswan-libs0-4.5.0-6.45.1
strongswan-libs0-debuginfo-4.5.0-6.45.1
strongswan-mysql-4.5.0-6.45.1
strongswan-mysql-debuginfo-4.5.0-6.45.1
strongswan-nm-4.5.0-6.45.1
strongswan-nm-debuginfo-4.5.0-6.45.1
strongswan-sqlite-4.5.0-6.45.1
strongswan-sqlite-debuginfo-4.5.0-6.45.1


References:

http://support.novell.com/security/cve/CVE-2012-2388.html
https://bugzilla.novell.com/761325


< Previous Next >
List Navigation
This Thread
  • No further messages