Mailinglist Archive: opensuse-updates (26 mails)

< Previous Next >
openSUSE-SU-2012:0474-1: update for openssl
openSUSE Security Update: update for openssl
______________________________________________________________________________

Announcement ID: openSUSE-SU-2012:0474-1
Rating: low
References: #749210 #749213 #751946
Cross-References: CVE-2012-1165
Affected Products:
openSUSE 12.1
openSUSE 11.4
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

Changes in openssl:
- S/MIME verification may erroneously fail
- Free headers after use in error message
- Symmetric crypto errors in PKCS7_decrypt


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.1:

zypper in -t patch openSUSE-2012-210

- openSUSE 11.4:

zypper in -t patch openSUSE-2012-210

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.1 (i586 x86_64):

libopenssl-devel-1.0.0e-34.9.1
libopenssl1_0_0-1.0.0e-34.9.1
libopenssl1_0_0-debuginfo-1.0.0e-34.9.1
openssl-1.0.0e-34.9.1
openssl-debuginfo-1.0.0e-34.9.1
openssl-debugsource-1.0.0e-34.9.1

- openSUSE 12.1 (x86_64):

libopenssl-devel-32bit-1.0.0e-34.9.1
libopenssl1_0_0-32bit-1.0.0e-34.9.1
libopenssl1_0_0-debuginfo-32bit-1.0.0e-34.9.1

- openSUSE 12.1 (noarch):

openssl-doc-1.0.0e-34.9.1

- openSUSE 12.1 (ia64):

libopenssl1_0_0-debuginfo-x86-1.0.0e-34.9.1
libopenssl1_0_0-x86-1.0.0e-34.9.1

- openSUSE 11.4 (i586 x86_64):

libopenssl-devel-1.0.0c-18.36.1
libopenssl1_0_0-1.0.0c-18.36.1
libopenssl1_0_0-debuginfo-1.0.0c-18.36.1
openssl-1.0.0c-18.36.1
openssl-debuginfo-1.0.0c-18.36.1
openssl-debugsource-1.0.0c-18.36.1

- openSUSE 11.4 (x86_64):

libopenssl1_0_0-32bit-1.0.0c-18.36.1
libopenssl1_0_0-debuginfo-32bit-1.0.0c-18.36.1

- openSUSE 11.4 (noarch):

openssl-doc-1.0.0c-18.36.1

- openSUSE 11.4 (ia64):

libopenssl1_0_0-debuginfo-x86-1.0.0c-18.36.1
libopenssl1_0_0-x86-1.0.0c-18.36.1


References:

http://support.novell.com/security/cve/CVE-2012-1165.html
https://bugzilla.novell.com/749210
https://bugzilla.novell.com/749213
https://bugzilla.novell.com/751946


< Previous Next >
This Thread
  • No further messages