Mailinglist Archive: opensuse-updates (12 mails)

< Previous Next >
openSUSE-SU-2011:1305-1: moderate: VUL-0: ruby on rails multiple vulnerabilities
openSUSE Security Update: VUL-0: ruby on rails multiple vulnerabilities
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:1305-1
Rating: moderate
References: #668817 #712057 #712058 #712062
Cross-References: CVE-2010-3933 CVE-2011-0446 CVE-2011-0447
CVE-2011-0448 CVE-2011-0449 CVE-2011-2930
CVE-2011-2931 CVE-2011-3186
Affected Products:
openSUSE 11.4
openSUSE 11.3
______________________________________________________________________________

An update that fixes 8 vulnerabilities is now available. It
includes two new package versions.

Description:

This update of rails fixes the following security issues:

CVE-2011-2930 - SQL-injection in quote_table_name function
via specially crafted column names (bnc#712062)
CVE-2011-2931 - Cross-Site Scripting (XSS) in the
strip_tags helper (bnc#712057) CVE-2011-3186 - Response
Splitting (bnc#712058) CVE-2010-3933 - Arbitrary
modification of records via specially crafted form
parameters (bnc#712058) CVE-2011-0446 - Cross-Site
Scripting (XSS) in the mail_to helper (bnc#668817)
CVE-2011-0447 - Improper validation of 'X-Requested-With'
header (bnc#668817) CVE-2011-0448 - SQL-injection caused by
improperly sanitized arguments to the limit function
(bnc#668817) CVE-2011-0449 - Bypass of access restrictions
via specially crafted action names (bnc#668817)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch rubygem-actionmailer-5440

- openSUSE 11.3:

zypper in -t patch rubygem-actionmailer-5440

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

rubygem-actionmailer-2_3-2.3.14-0.3.1
rubygem-actionmailer-2_3-doc-2.3.14-0.3.1
rubygem-actionmailer-2_3-testsuite-2.3.14-0.3.1
rubygem-actionpack-2_3-2.3.14-0.3.1
rubygem-actionpack-2_3-doc-2.3.14-0.3.1
rubygem-actionpack-2_3-testsuite-2.3.14-0.3.1
rubygem-activerecord-2_3-2.3.14-0.3.1
rubygem-activerecord-2_3-doc-2.3.14-0.3.1
rubygem-activerecord-2_3-testsuite-2.3.14-0.3.1
rubygem-activeresource-2_3-2.3.14-0.3.1
rubygem-activeresource-2_3-doc-2.3.14-0.3.1
rubygem-activeresource-2_3-testsuite-2.3.14-0.3.1
rubygem-activesupport-2_3-2.3.14-0.3.1
rubygem-activesupport-2_3-doc-2.3.14-0.3.1
rubygem-rack-1.1.2-0.3.1
rubygem-rails-2_3-2.3.14-0.3.1
rubygem-rails-2_3-doc-2.3.14-0.3.1

- openSUSE 11.4 (noarch):

rubygem-actionmailer-2.3.14-0.3.1
rubygem-actionpack-2.3.14-0.3.1
rubygem-activerecord-2.3.14-0.3.1
rubygem-activeresource-2.3.14-0.3.1
rubygem-activesupport-2.3.14-0.3.1
rubygem-rails-2.3.14-0.3.1

- openSUSE 11.3 (i586 x86_64) [New Version: 1.1.2 and 2.3.14]:

rubygem-actionmailer-2_3-2.3.14-0.3.1
rubygem-actionpack-2_3-2.3.14-0.2.1
rubygem-activerecord-2_3-2.3.14-0.3.1
rubygem-activeresource-2_3-2.3.14-0.3.1
rubygem-activesupport-2_3-2.3.14-0.3.1
rubygem-rack-1.1.2-0.3.1
rubygem-rails-2_3-2.3.14-0.3.1

- openSUSE 11.3 (noarch) [New Version: 2.3.14]:

rubygem-actionmailer-2.3.14-0.3.1
rubygem-actionpack-2.3.14-0.3.1
rubygem-activerecord-2.3.14-0.3.1
rubygem-activeresource-2.3.14-0.3.1
rubygem-activesupport-2.3.14-0.3.1
rubygem-rails-2.3.14-0.3.1


References:

http://support.novell.com/security/cve/CVE-2010-3933.html
http://support.novell.com/security/cve/CVE-2011-0446.html
http://support.novell.com/security/cve/CVE-2011-0447.html
http://support.novell.com/security/cve/CVE-2011-0448.html
http://support.novell.com/security/cve/CVE-2011-0449.html
http://support.novell.com/security/cve/CVE-2011-2930.html
http://support.novell.com/security/cve/CVE-2011-2931.html
http://support.novell.com/security/cve/CVE-2011-3186.html
https://bugzilla.novell.com/668817
https://bugzilla.novell.com/712057
https://bugzilla.novell.com/712058
https://bugzilla.novell.com/712062


< Previous Next >
This Thread
  • No further messages