Mailinglist Archive: opensuse-updates (36 mails)

< Previous Next >
openSUSE-SU-2011:1137-1: moderate: php5
openSUSE Security Update: php5
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:1137-1
Rating: moderate
References: #699711 #701491 #709549 #715646
Cross-References: CVE-2011-2202 CVE-2011-2483 CVE-2011-3268

Affected Products:
openSUSE 11.3
______________________________________________________________________________

An update that solves three vulnerabilities and has one
errata is now available. It includes one version update.

Description:

The blowfish password hashing implementation did not
properly handle 8-characters in passwords, which made it
easier for attackers to crack the hash (CVE-2011-2483).
After this update existing hashes with id "$2a$" for
passwords that contain 8-bit characters will no longer be
compatible with newly generated hashes. Affected users will
either have to change their password to store a new hash or
the id of the existing hash has to be manually changed to
"$2x$" in order to activate a compat mode. Please see the
description of the CVE-2011-2483 glibc update for details.

File uploads could potentially overwrite files owned by the
user running php (CVE-2011-2202).

A long salt argument to the crypt function could cause a
buffer overflow (CVE-2011-3268)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch apache2-mod_php5-5112

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64) [New Version: 5.3.3]:

apache2-mod_php5-5.3.3-0.21.1
php5-5.3.3-0.21.1
php5-bcmath-5.3.3-0.21.1
php5-bz2-5.3.3-0.21.1
php5-calendar-5.3.3-0.21.1
php5-ctype-5.3.3-0.21.1
php5-curl-5.3.3-0.21.1
php5-dba-5.3.3-0.21.1
php5-devel-5.3.3-0.21.1
php5-dom-5.3.3-0.21.1
php5-enchant-5.3.3-0.21.1
php5-exif-5.3.3-0.21.1
php5-fastcgi-5.3.3-0.21.1
php5-fileinfo-5.3.3-0.21.1
php5-ftp-5.3.3-0.21.1
php5-gd-5.3.3-0.21.1
php5-gettext-5.3.3-0.21.1
php5-gmp-5.3.3-0.21.1
php5-hash-5.3.3-0.21.1
php5-iconv-5.3.3-0.21.1
php5-imap-5.3.3-0.21.1
php5-intl-5.3.3-0.21.1
php5-json-5.3.3-0.21.1
php5-ldap-5.3.3-0.21.1
php5-mbstring-5.3.3-0.21.1
php5-mcrypt-5.3.3-0.21.1
php5-mysql-5.3.3-0.21.1
php5-odbc-5.3.3-0.21.1
php5-openssl-5.3.3-0.21.1
php5-pcntl-5.3.3-0.21.1
php5-pdo-5.3.3-0.21.1
php5-pgsql-5.3.3-0.21.1
php5-phar-5.3.3-0.21.1
php5-posix-5.3.3-0.21.1
php5-pspell-5.3.3-0.21.1
php5-readline-5.3.3-0.21.1
php5-shmop-5.3.3-0.21.1
php5-snmp-5.3.3-0.21.1
php5-soap-5.3.3-0.21.1
php5-sockets-5.3.3-0.21.1
php5-sqlite-5.3.3-0.21.1
php5-suhosin-5.3.3-0.21.1
php5-sysvmsg-5.3.3-0.21.1
php5-sysvsem-5.3.3-0.21.1
php5-sysvshm-5.3.3-0.21.1
php5-tidy-5.3.3-0.21.1
php5-tokenizer-5.3.3-0.21.1
php5-wddx-5.3.3-0.21.1
php5-xmlreader-5.3.3-0.21.1
php5-xmlrpc-5.3.3-0.21.1
php5-xmlwriter-5.3.3-0.21.1
php5-xsl-5.3.3-0.21.1
php5-zip-5.3.3-0.21.1
php5-zlib-5.3.3-0.21.1

- openSUSE 11.3 (noarch) [New Version: 5.3.3]:

php5-pear-5.3.3-0.21.1


References:

http://support.novell.com/security/cve/CVE-2011-2202.html
http://support.novell.com/security/cve/CVE-2011-2483.html
http://support.novell.com/security/cve/CVE-2011-3268.html
https://bugzilla.novell.com/699711
https://bugzilla.novell.com/701491
https://bugzilla.novell.com/709549
https://bugzilla.novell.com/715646


< Previous Next >
This Thread
  • No further messages