Mailinglist Archive: opensuse-updates (36 mails)

< Previous Next >
openSUSE-SU-2011:1135-1: moderate: kdelibs4: fixing input validation flaw when displaying certificates (CVE-2011-3365)
openSUSE Security Update: kdelibs4: fixing input validation flaw when
displaying certificates (CVE-2011-3365)
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:1135-1
Rating: moderate
References: #721974
Cross-References: CVE-2011-3365
Affected Products:
openSUSE 11.4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

An input validation flaw when displaying certificates has
been fixed in KDE's KSSL (kdelibs4). CVE-2011-3365 has been
assigned to this issue.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch kdelibs4-5258

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

kdelibs4-4.6.0-6.17.1
kdelibs4-branding-upstream-4.6.0-6.17.1
kdelibs4-core-4.6.0-6.17.1
kdelibs4-doc-4.6.0-6.17.1
libkde4-4.6.0-6.17.1
libkde4-devel-4.6.0-6.17.1
libkdecore4-4.6.0-6.17.1
libkdecore4-devel-4.6.0-6.17.1
libksuseinstall-devel-4.6.0-6.17.1
libksuseinstall1-4.6.0-6.17.1

- openSUSE 11.4 (x86_64):

libkde4-32bit-4.6.0-6.17.1
libkdecore4-32bit-4.6.0-6.17.1
libksuseinstall1-32bit-4.6.0-6.17.1


References:

http://support.novell.com/security/cve/CVE-2011-3365.html
https://bugzilla.novell.com/721974


< Previous Next >
This Thread
  • No further messages