Mailinglist Archive: opensuse-updates (37 mails)

< Previous Next >
openSUSE-SU-2011:1060-1: : Flash-Player: Update to 10.3.183.10
openSUSE Security Update: Flash-Player: Update to 10.3.183.10
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:1060-1
Rating:
References: #719400
Cross-References: CVE-2011-2426 CVE-2011-2427 CVE-2011-2428
CVE-2011-2429 CVE-2011-2430 CVE-2011-2444

Affected Products:
openSUSE 11.4
openSUSE 11.3
______________________________________________________________________________

An update that fixes 6 vulnerabilities is now available. It
includes one version update.

Description:

This update resolves a universal cross-site scripting issue
that could be used to take actions on a user's behalf on
any website or webmail provider if the user visits a
malicious website (CVE-2011-2444).

Note: There are reports that this issue is being exploited
in the wild in active targeted attacks designed to trick
the user into clicking on a malicious link delivered in an
email message.

This update resolves an AVM stack overflow issue that may
allow for remote code execution. (CVE-2011-2426).

This update resolves an AVM stack overflow issue that may
lead to denial of service and code execution.
(CVE-2011-2427).

This update resolves a logic error issue which causes a
browser crash and may lead to code execution. (CVE-2011-
2428).

This update resolves a Flash Player security control
bypass which could allow information disclosure.
(CVE-2011-2429).

This update resolves a streaming media logic error
vulnerability which could lead to code execution.
(CVE-2011-2430).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch flash-player-5183

- openSUSE 11.3:

zypper in -t patch flash-player-5183

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586) [New Version: 10.3.183.10]:

flash-player-10.3.183.10-0.2.1

- openSUSE 11.3 (i586) [New Version: 10.3.183.10]:

flash-player-10.3.183.10-0.2.1


References:

http://support.novell.com/security/cve/CVE-2011-2426.html
http://support.novell.com/security/cve/CVE-2011-2427.html
http://support.novell.com/security/cve/CVE-2011-2428.html
http://support.novell.com/security/cve/CVE-2011-2429.html
http://support.novell.com/security/cve/CVE-2011-2430.html
http://support.novell.com/security/cve/CVE-2011-2444.html
https://bugzilla.novell.com/719400


< Previous Next >
This Thread
  • No further messages