Mailinglist Archive: opensuse-updates (50 mails)

< Previous Next >
openSUSE-RU-2011:0926-1: important: yasm: Update to YASM 1.1.0
openSUSE Recommended Update: yasm: Update to YASM 1.1.0
______________________________________________________________________________

Announcement ID: openSUSE-RU-2011:0926-1
Rating: important
References: #712224
Affected Products:
openSUSE 11.3
______________________________________________________________________________

An update that has one recommended fix can now be
installed. It includes one version update.

Description:

YASM was updated to 1.1.0 to ensure newer Mozilla versions
still build.

Changes:
- update to 1.1.0
* Fix a number of issues with Win32 SAFESEH support
(#139).
* Fix several 32-bit Mach-O (macho32) bugs (#212 and
others).
* Add Intel post-32nm instructions (section 7 of AVX
spec).
* Add XSAVEOPT, INVEPT, INVVPID, and GETSEC instructions
(#211).
* Remove AMD CVT16 instructions.
* Don't emit unnecessary REX.W for pinsrw instruction
(#207).
* Update gettext to 0.17 (#206).
- update to 1.0.1
* Fix ELF32 shared object relocations (#202).
* Ignore [warning] directive (#201).
- update to 1.0.0
* Add GAS preprocessor (fixes #79).
* Add Visual Studio 2010 special frontend, vsyasm
* Add support for AMD XOP, FMA4, and CVT16 instructions
(replacing SSE5).
* Add support for %scope and %endscope NASM macros
* Add support for %{x:y} parameter list expansion in NASM
preprocessor
* Fix _GLOBAL_OFFSET_TABLE_
* Add support for ELF64 PC-relative relocations and
latest ELF32 relocation types.
* Add support for ELF tlsdesc, tlscall, pltoff, gotplt,
gotoff special symbols.
* NASM preprocessor license has been changed to 2-clause
BSD.
* Various bugfixes in TASM syntax support.
* Many other bugfixes


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch yasm-5017

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64) [New Version: 1.1.0]:

yasm-1.1.0-10.3.1
yasm-devel-1.1.0-10.3.1


References:

https://bugzilla.novell.com/712224


< Previous Next >
This Thread
  • No further messages