Mailinglist Archive: opensuse-updates (42 mails)

< Previous Next >
openSUSE-RU-2011:0777-1: apparmor: Various fixes to profiles and userspace programs
openSUSE Recommended Update: apparmor: Various fixes to profiles and
userspace programs
______________________________________________________________________________

Announcement ID: openSUSE-RU-2011:0777-1
Rating: low
References: #666450 #678749 #679182 #681267 #682909 #682912
#685674 #696553 #701821 #702427
Affected Products:
openSUSE 11.4
______________________________________________________________________________

An update that has 10 recommended fixes can now be
installed.

Description:

The apparmor userspace code and profiles is updated to fix
various issues:

- Fixed building of pam_apparmor to properly link libpam
(bnc#696553).
- Fixed building of apache2-mod_apparmor to properly link
(bnc#701821).
- Added perl-File-Tail dependency for aa-eventd
(bnc#666450).
- Add raw network access to traceroute profile (bnc#685674).
- Updated dovecot profile (bnc#681267).
- Changed apparmor-docs and apparmor-profiles back to
noarch (bnc#682909 bnc#682912).
- Add config files to samba profiles (bnc#666450
bnc#679182).
- Added /etc/ethers and /var/run/dnsmasq-forwarders to
usr.sbin.dnsmasq (bnc#678749)


Special Instructions and Notes:

This update triggers a restart of the software management
stack. More updates will be available for installation
after applying this update and restarting the application.
This update triggers a restart of the software management
stack. More updates will be available for installation
after applying this update and restarting the application.
This update triggers a restart of the software management
stack. More updates will be available for installation
after applying this update and restarting the application.

Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch apache2-mod_apparmor-4816

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

apache2-mod_apparmor-2.5.1.r1445-52.59.1
apparmor-parser-2.5.1.r1445-52.59.1
libapparmor-devel-2.5.1.r1445-52.59.1
libapparmor1-2.5.1.r1445-52.59.1
pam_apparmor-2.5.1.r1445-52.59.1
perl-apparmor-2.5.1.r1445-52.59.1
tomcat_apparmor-2.5.1.r1445-52.59.1

- openSUSE 11.4 (x86_64):

libapparmor1-32bit-2.5.1.r1445-52.59.1
pam_apparmor-32bit-2.5.1.r1445-52.59.1

- openSUSE 11.4 (noarch):

apparmor-docs-2.5.1.r1445-52.59.1
apparmor-profiles-2.5.1.r1445-52.59.1
apparmor-utils-2.5.1.r1445-52.59.1


References:

https://bugzilla.novell.com/666450
https://bugzilla.novell.com/678749
https://bugzilla.novell.com/679182
https://bugzilla.novell.com/681267
https://bugzilla.novell.com/682909
https://bugzilla.novell.com/682912
https://bugzilla.novell.com/685674
https://bugzilla.novell.com/696553
https://bugzilla.novell.com/701821
https://bugzilla.novell.com/702427


< Previous Next >
This Thread
  • No further messages