Mailinglist Archive: opensuse-updates (67 mails)

< Previous Next >
openSUSE-SU-2011:0484-1 (moderate): python security update
openSUSE Security Update: python security update
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0484-1
Rating: moderate
References: #682554
Cross-References: CVE-2011-1521
Affected Products:
openSUSE 11.4
openSUSE 11.3
openSUSE 11.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update of python fixes a possible denial of service
bug or information leakage vulnerability while using
user-crafted ftp:// or file:// URLs with urllib(2).
CVE-2011-1521: CVSS v2 Base Score: 6.4
(AV:N/AC:L/Au:N/C:P/I:N/A:P)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch libpython2_6-1_0-4508

- openSUSE 11.3:

zypper in -t patch libpython2_6-1_0-4508

- openSUSE 11.2:

zypper in -t patch libpython2_6-1_0-4508

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

libpython2_7-1_0-2.7-8.10.2
python-2.7-9.10.2
python-base-2.7-8.10.2
python-curses-2.7-9.10.2
python-demo-2.7-9.10.2
python-devel-2.7-8.10.2
python-gdbm-2.7-9.10.2
python-idle-2.7-9.10.2
python-tk-2.7-9.10.2
python-xml-2.7-8.10.2

- openSUSE 11.4 (x86_64):

libpython2_7-1_0-32bit-2.7-8.10.2
python-32bit-2.7-9.10.2
python-base-32bit-2.7-8.10.2

- openSUSE 11.3 (i586 x86_64):

libpython2_6-1_0-2.6.5-3.5.2
python-2.6.5-3.5.1
python-base-2.6.5-3.5.2
python-curses-2.6.5-3.5.1
python-demo-2.6.5-3.5.1
python-devel-2.6.5-3.5.2
python-gdbm-2.6.5-3.5.1
python-idle-2.6.5-3.5.1
python-tk-2.6.5-3.5.1
python-xml-2.6.5-3.5.2

- openSUSE 11.3 (x86_64):

libpython2_6-1_0-32bit-2.6.5-3.5.2
python-32bit-2.6.5-3.5.1
python-base-32bit-2.6.5-3.5.2

- openSUSE 11.2 (i586 x86_64):

libpython2_6-1_0-2.6.2-6.9.2
python-2.6.2-6.9.1
python-base-2.6.2-6.9.2
python-curses-2.6.2-6.9.1
python-demo-2.6.2-6.9.1
python-devel-2.6.2-6.9.2
python-gdbm-2.6.2-6.9.1
python-idle-2.6.2-6.9.1
python-tk-2.6.2-6.9.1
python-xml-2.6.2-6.9.2

- openSUSE 11.2 (x86_64):

libpython2_6-1_0-32bit-2.6.2-6.9.2
python-32bit-2.6.2-6.9.1
python-base-32bit-2.6.2-6.9.2


References:

http://support.novell.com/security/cve/CVE-2011-1521.html
https://bugzilla.novell.com/682554


< Previous Next >
This Thread
  • No further messages