Mailinglist Archive: opensuse-updates (67 mails)

< Previous Next >
openSUSE-SU-2011:0449-1 (low): libzip security update
openSUSE Security Update: libzip security update
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0449-1
Rating: low
References: #681193
Cross-References: CVE-2011-0421
Affected Products:
openSUSE 11.4
openSUSE 11.3
openSUSE 11.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

empty zip archives could crash programs using libzip
(CVE-2011-0421).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch libzip-devel-4188

- openSUSE 11.3:

zypper in -t patch libzip-devel-4188

- openSUSE 11.2:

zypper in -t patch libzip-devel-4188

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

libzip-devel-0.9-30.31.1
libzip-util-0.9-30.31.1
libzip1-0.9-30.31.1

- openSUSE 11.3 (i586 x86_64):

libzip-devel-0.9-27.3.1
libzip-util-0.9-27.3.1
libzip1-0.9-27.3.1

- openSUSE 11.2 (i586 x86_64):

libzip-devel-0.9-23.4.1
libzip-util-0.9-23.4.1
libzip1-0.9-23.4.1


References:

http://support.novell.com/security/cve/CVE-2011-0421.html
https://bugzilla.novell.com/681193


< Previous Next >
This Thread
  • No further messages