Mailinglist Archive: opensuse-updates (42 mails)

< Previous Next >
openSUSE-SU-2011:0221-1 (important): pango security update
openSUSE Security Update: pango security update
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0221-1
Rating: important
References: #666101 #672502
Cross-References: CVE-2011-0020 CVE-2011-0064
Affected Products:
openSUSE 11.3
openSUSE 11.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.
It includes one version update.

Description:

Specially crafted font files could cause a heap corruption
in applications linked against pango (CVE-2011-0064,
CVE-2011-0020).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch libpango-1_0-0-4076

- openSUSE 11.2:

zypper in -t patch libpango-1_0-0-4076

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64):

pango-1.28.0-3.3.1
pango-devel-1.28.0-3.3.1
pango-module-thai-lang-1.28.0-3.3.1

- openSUSE 11.3 (x86_64):

pango-32bit-1.28.0-3.3.1

- openSUSE 11.2 (i586 x86_64) [New Version: 1.26.2]:

pango-1.26.2-1.3.1
pango-devel-1.26.2-1.3.1
pango-module-thai-lang-1.26.2-1.3.1

- openSUSE 11.2 (x86_64) [New Version: 1.26.2]:

pango-32bit-1.26.2-1.3.1


References:

http://support.novell.com/security/cve/CVE-2011-0020.html
http://support.novell.com/security/cve/CVE-2011-0064.html
https://bugzilla.novell.com/666101
https://bugzilla.novell.com/672502


< Previous Next >
This Thread
  • No further messages