Mailinglist Archive: opensuse-updates (19 mails)

< Previous Next >
openSUSE-SU-2011:0092-1 (moderate): Fixing integer and buffer overflow in pcsc-ccid and pcsc-lite (CVE-2010-4530,CVE-2010-4531).
openSUSE Security Update: Fixing integer and buffer overflow in pcsc-ccid
and pcsc-lite (CVE-2010-4530,CVE-2010-4531).
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0092-1
Rating: moderate
References: #661000
Cross-References: CVE-2010-4530 CVE-2010-4531
Affected Products:
openSUSE 11.3
openSUSE 11.2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

An integer overflow in pcsc-ccid and a buffer overflow in
pcsc-lite while handling smart card responses have been
fixed. CVE-2010-4530 and CVE-2010-4531 have been assigned
to these issues.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch libpcsclite1-3770

- openSUSE 11.2:

zypper in -t patch libpcsclite1-3770

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64):

libpcsclite1-1.5.5-7.3.1
pcsc-ccid-1.3.11-6.3.1
pcsc-lite-1.5.5-7.3.1
pcsc-lite-devel-1.5.5-7.3.1

- openSUSE 11.3 (x86_64):

libpcsclite1-32bit-1.5.5-7.3.1

- openSUSE 11.2 (i586 x86_64):

libpcsclite1-1.5.5-2.4.1
pcsc-ccid-1.3.11-2.3.1
pcsc-lite-1.5.5-2.4.1
pcsc-lite-devel-1.5.5-2.4.1

- openSUSE 11.2 (x86_64):

libpcsclite1-32bit-1.5.5-2.4.1


References:

http://support.novell.com/security/cve/CVE-2010-4530.html
http://support.novell.com/security/cve/CVE-2010-4531.html
https://bugzilla.novell.com/661000


< Previous Next >
List Navigation
This Thread
  • No further messages