Mailinglist Archive: opensuse-updates (35 mails)

< Previous Next >
openSUSE-SU-2011:0068-1 (moderate): hplip security update (CVE-2010-4267)
openSUSE Security Update: hplip security update (CVE-2010-4267)
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0068-1
Rating: moderate
References: #336658
Cross-References: CVE-2010-4267
Affected Products:
openSUSE 11.3
openSUSE 11.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

Specially crafted SNMP replies could cause a buffer
overflow in hplip's sane backend (CVE-2010-4267).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch hplip-3814

- openSUSE 11.2:

zypper in -t patch hplip-3814

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64):

hplip-3.10.2-2.3.1
hplip-hpijs-3.10.2-2.3.1

- openSUSE 11.2 (i586 x86_64):

hplip-3.9.8-3.6.1
hplip-hpijs-3.9.8-3.6.1


References:

http://support.novell.com/security/cve/CVE-2010-4267.html
https://bugzilla.novell.com/336658


< Previous Next >
This Thread
  • No further messages