Mailinglist Archive: opensuse-updates (35 mails)

< Previous Next >
openSUSE-SU-2011:0049-1 (important): opensc security update
openSUSE Security Update: opensc security update
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0049-1
Rating: important
References: #660109
Cross-References: CVE-2010-4523
Affected Products:
openSUSE 11.3
openSUSE 11.2
openSUSE 11.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

Specially crafted smart cards could cause a buffer overflow
in opensc (CVE-2010-4523).


Special Instructions and Notes:

Please reboot the system after installing this update.

Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch libopensc2-3737

- openSUSE 11.2:

zypper in -t patch libopensc2-3737

- openSUSE 11.1:

zypper in -t patch libopensc2-3737

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64):

libopensc2-0.11.13-2.3.1
opensc-0.11.13-2.3.1
opensc-devel-0.11.13-2.3.1

- openSUSE 11.3 (x86_64):

libopensc2-32bit-0.11.13-2.3.1
opensc-32bit-0.11.13-2.3.1

- openSUSE 11.2 (i586 x86_64):

libopensc2-0.11.9-2.3.1
opensc-0.11.9-2.3.1
opensc-devel-0.11.9-2.3.1

- openSUSE 11.2 (x86_64):

libopensc2-32bit-0.11.9-2.3.1
opensc-32bit-0.11.9-2.3.1

- openSUSE 11.1 (i586 ppc x86_64):

libopensc2-0.11.6-5.3.1
opensc-0.11.6-5.3.1
opensc-devel-0.11.6-5.3.1

- openSUSE 11.1 (x86_64):

libopensc2-32bit-0.11.6-5.3.1
opensc-32bit-0.11.6-5.3.1

- openSUSE 11.1 (ppc):

libopensc2-64bit-0.11.6-5.3.1
opensc-64bit-0.11.6-5.3.1


References:

http://support.novell.com/security/cve/CVE-2010-4523.html
https://bugzilla.novell.com/660109


< Previous Next >
This Thread
  • No further messages