Mailinglist Archive: opensuse-updates (48 mails)

< Previous Next >
openSUSE-SU-2010:0727-1 (moderate): squid: remote crash by trusted client
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Fri, 15 Oct 2010 15:08:14 +0200 (CEST)
  • Message-id: <20101015130814.C123CBE45@xxxxxxxxxxxxxx>
openSUSE Security Update: squid: remote crash by trusted client
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0727-1
Rating: moderate
References: #637287
Cross-References: CVE-2010-3072
Affected Products:
openSUSE 11.3
openSUSE 11.2
openSUSE 11.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

A remote trusted client can cause a NULL pointer
dereference within squid to make it crash. (CVE-2010-3072:
CVSS v2 Base Score: 5.0)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch squid3-3328

- openSUSE 11.2:

zypper in -t patch squid3-3328

- openSUSE 11.1:

zypper in -t patch squid3-3328

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64):

squid3-3.0.STABLE25-2.1.1

- openSUSE 11.2 (i586 x86_64):

squid3-3.0.STABLE18-3.6.1

- openSUSE 11.1 (i586 ppc x86_64):

squid3-3.0.STABLE10-2.14.1


References:

http://support.novell.com/security/cve/CVE-2010-3072.html
https://bugzilla.novell.com/637287


< Previous Next >
This Thread
  • No further messages