Mailinglist Archive: opensuse-updates (59 mails)

< Previous Next >
openSUSE-SU-2010:0654-1 (critical): Linux Kernel: Security/Bugfix update to fix local privilege escalations
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Thu, 23 Sep 2010 01:08:23 +0200 (CEST)
  • Message-id: <20100922230823.5252DBE38@xxxxxxxxxxxxxx>
openSUSE Security Update: Linux Kernel: Security/Bugfix update to fix local
privilege escalations
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0654-1
Rating: critical
References: #633581 #639708 #639709
Affected Products:
openSUSE 11.1
______________________________________________________________________________

An update that contains security fixes can now be
installed. It includes one version update.

Description:

This security update of the openSUSE 11.1 kernel fixes 3
critical security issues.

Following security bugs were fixed: CVE-2010-3301: Mismatch
between 32bit and 64bit register usage in the system call
entry path could be used by local attackers to gain root
privileges. This problem only affects x86_64 kernels.

CVE-2010-3081: Incorrect buffer handling in the
biarch-compat buffer handling could be used by local
attackers to gain root privileges. This problem affects
foremost x86_64, or potentially other biarch platforms,
like PowerPC and S390x.

CVE-2010-2959: Integer overflow in net/can/bcm.c in the
Controller Area Network (CAN) implementation in the Linux
kernel allowed attackers to execute arbitrary code or cause
a denial of service (system crash) via crafted CAN traffic.


Special Instructions and Notes:

Please reboot the system after installing this update.

Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.1:

zypper in -t patch kernel-3174

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.1 (i586 ppc x86_64) [New Version: 2.6.27.48]:

kernel-default-2.6.27.48-0.3.1
kernel-default-base-2.6.27.48-0.3.1
kernel-default-extra-2.6.27.48-0.3.1
kernel-source-2.6.27.48-0.3.1
kernel-syms-2.6.27.48-0.3.1
kernel-vanilla-2.6.27.48-0.3.1

- openSUSE 11.1 (i586 x86_64) [New Version: 2.6.27.48]:

kernel-debug-2.6.27.48-0.3.1
kernel-debug-base-2.6.27.48-0.3.1
kernel-debug-extra-2.6.27.48-0.3.1
kernel-trace-2.6.27.48-0.3.1
kernel-trace-base-2.6.27.48-0.3.1
kernel-trace-extra-2.6.27.48-0.3.1
kernel-xen-2.6.27.48-0.3.1
kernel-xen-base-2.6.27.48-0.3.1
kernel-xen-extra-2.6.27.48-0.3.1

- openSUSE 11.1 (noarch):

kernel-docs-2.6.3-3.13.116

- openSUSE 11.1 (i586) [New Version: 2.6.27.48]:

kernel-pae-2.6.27.48-0.3.1
kernel-pae-base-2.6.27.48-0.3.1
kernel-pae-extra-2.6.27.48-0.3.1

- openSUSE 11.1 (ppc) [New Version: 2.6.27.48]:

kernel-kdump-2.6.27.48-0.3.1
kernel-ppc64-2.6.27.48-0.3.1
kernel-ppc64-base-2.6.27.48-0.3.1
kernel-ppc64-extra-2.6.27.48-0.3.1
kernel-ps3-2.6.27.48-0.3.1


References:

https://bugzilla.novell.com/633581
https://bugzilla.novell.com/639708
https://bugzilla.novell.com/639709


< Previous Next >
This Thread
  • No further messages