Mailinglist Archive: opensuse-updates (59 mails)

< Previous Next >
openSUSE-SU-2010:0625-1 (important): libvirt security update
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Thu, 16 Sep 2010 17:08:17 +0200 (CEST)
  • Message-id: <20100916150817.C1CD6BE37@xxxxxxxxxxxxxx>
openSUSE Security Update: libvirt security update
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0625-1
Rating: important
References: #618155 #619991
Cross-References: CVE-2010-2237 CVE-2010-2238 CVE-2010-2239
CVE-2010-2242
Affected Products:
openSUSE 11.3
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

libvirt did not properly handle configured disk formats
which potenially allowed users to read arbitrary files
(CVE-2010-2237, CVE-2010-2238, CVE-2010-2239)

Improperly mapped source privileged ports in guests may
allow obtaining privileged resources on the host
(CVE-2010-2242).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch libvirt-2903

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64):

libvirt-0.8.1-4.2.1
libvirt-client-0.8.1-4.2.1
libvirt-devel-0.8.1-4.2.1
libvirt-doc-0.8.1-4.2.1
libvirt-python-0.8.1-4.2.1


References:

http://support.novell.com/security/cve/CVE-2010-2237.html
http://support.novell.com/security/cve/CVE-2010-2238.html
http://support.novell.com/security/cve/CVE-2010-2239.html
http://support.novell.com/security/cve/CVE-2010-2242.html
https://bugzilla.novell.com/618155
https://bugzilla.novell.com/619991


< Previous Next >
This Thread
  • No further messages