Mailinglist Archive: opensuse-updates (59 mails)

< Previous Next >
openSUSE-SU-2010:0620-1 (important): libvirt: security fix for multiple issues
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Thu, 16 Sep 2010 16:08:16 +0200 (CEST)
  • Message-id: <20100916140816.92B76BE37@xxxxxxxxxxxxxx>
openSUSE Security Update: libvirt: security fix for multiple issues
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0620-1
Rating: important
References: #618155
Cross-References: CVE-2010-2237 CVE-2010-2238 CVE-2010-2239
CVE-2010-2242
Affected Products:
openSUSE 11.2
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

libvirt did not properly handle configured disk formats
which potenially allowed users to read arbitrary files
(CVE-2010-2237, CVE-2010-2238, CVE-2010-2239)

Improperly mapped source privileged ports in guests may
allow obtaining privileged resources on the host
(CVE-2010-2242).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.2:

zypper in -t patch libvirt-2892

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.2 (i586 x86_64):

libvirt-0.7.2-1.1.3.5
libvirt-devel-0.7.2-1.1.3.5
libvirt-doc-0.7.2-1.1.3.5
libvirt-python-0.7.2-1.1.3.5


References:

http://support.novell.com/security/cve/CVE-2010-2237.html
http://support.novell.com/security/cve/CVE-2010-2238.html
http://support.novell.com/security/cve/CVE-2010-2239.html
http://support.novell.com/security/cve/CVE-2010-2242.html
https://bugzilla.novell.com/618155


< Previous Next >
This Thread
  • No further messages