Mailinglist Archive: opensuse-updates (59 mails)

< Previous Next >
openSUSE-SU-2010:0594-1 (important): libpng security update
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Thu, 9 Sep 2010 18:11:04 +0200 (CEST)
  • Message-id: <20100909161104.CAEF6BE31@xxxxxxxxxxxxxx>
openSUSE Security Update: libpng security update
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0594-1
Rating: important
References: #617866
Cross-References: CVE-2010-1205 CVE-2010-2249
Affected Products:
openSUSE 11.2
openSUSE 11.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

Specially crafted png files could cause crashes or even
execution of arbitrary code in applications using libpng to
process such files (CVE-2010-1205, CVE-2010-2249).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.2:

zypper in -t patch libpng-devel-3065

- openSUSE 11.1:

zypper in -t patch libpng-devel-3065

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.2 (i586 x86_64):

libpng-devel-1.2.39-2.4.1
libpng12-0-1.2.39-2.4.1
libpng3-1.2.39-2.4.1

- openSUSE 11.2 (x86_64):

libpng-devel-32bit-1.2.39-2.4.1
libpng12-0-32bit-1.2.39-2.4.1

- openSUSE 11.1 (i586 ppc x86_64):

libpng-devel-1.2.31-4.40.1
libpng12-0-1.2.31-4.40.1
libpng3-1.2.31-4.40.1

- openSUSE 11.1 (x86_64):

libpng-devel-32bit-1.2.31-4.40.1
libpng12-0-32bit-1.2.31-4.40.1

- openSUSE 11.1 (ppc):

libpng-devel-64bit-1.2.31-4.40.1
libpng12-0-64bit-1.2.31-4.40.1


References:

http://support.novell.com/security/cve/CVE-2010-1205.html
http://support.novell.com/security/cve/CVE-2010-2249.html
https://bugzilla.novell.com/617866


< Previous Next >
This Thread
  • No further messages