Mailinglist Archive: opensuse-updates (57 mails)

< Previous Next >
openSUSE-SU-2010:0351-1 (moderate): libvorbis: memory corruption while parsing ogg files
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Fri, 2 Jul 2010 20:08:09 +0200 (CEST)
  • Message-id: <20100702180809.59421BE26@xxxxxxxxxxxxxx>
openSUSE Security Update: libvorbis: memory corruption while parsing ogg
files
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0351-1
Rating: moderate
References: #608192
Cross-References: CVE-2009-2663
Affected Products:
openSUSE 11.2
openSUSE 11.1
openSUSE 11.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update of libvorbis fixes a memory corruption while
parsing OGG files. This bug was exploitable by remote
attackers to cause an application crash and could probably
be exploited to execute arbitrary code. CVE-2009-2663: CVSS
v2 Base Score: 6.8 (important)
(AV:N/AC:M/Au:N/C:P/I:P/A:P): Resource Management Errors
(CWE-399)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.2:

zypper in -t patch libvorbis-2492

- openSUSE 11.1:

zypper in -t patch libvorbis-2492

- openSUSE 11.0:

zypper in -t patch libvorbis-2492

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.2 (i586 src x86_64):

libvorbis-1.2.0-83.3.1

- openSUSE 11.2 (i586 x86_64):

libvorbis-devel-1.2.0-83.3.1
libvorbis-doc-1.2.0-83.3.1

- openSUSE 11.2 (x86_64):

libvorbis-32bit-1.2.0-83.3.1

- openSUSE 11.1 (i586 ppc src x86_64):

libvorbis-1.2.0-78.17.1

- openSUSE 11.1 (i586 ppc x86_64):

libvorbis-devel-1.2.0-78.17.1
libvorbis-doc-1.2.0-78.17.1

- openSUSE 11.1 (x86_64):

libvorbis-32bit-1.2.0-78.17.1

- openSUSE 11.1 (ppc):

libvorbis-64bit-1.2.0-78.17.1

- openSUSE 11.0 (i586 ppc src x86_64):

libvorbis-1.2.0-53.3

- openSUSE 11.0 (i586 ppc x86_64):

libvorbis-devel-1.2.0-53.3
libvorbis-doc-1.2.0-53.3

- openSUSE 11.0 (x86_64):

libvorbis-32bit-1.2.0-53.3

- openSUSE 11.0 (ppc):

libvorbis-64bit-1.2.0-53.3


References:

http://support.novell.com/security/cve/CVE-2009-2663.html
https://bugzilla.novell.com/608192


< Previous Next >
List Navigation
This Thread
  • No further messages