Mailinglist Archive: opensuse-updates (31 mails)

< Previous Next >
openSUSE-SU-2010:0292-1 (moderate): krb5: security update for remote denial-of-service vulnerability
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Tue, 25 May 2010 23:08:15 +0200 (CEST)
  • Message-id: <20100525210815.B3E06BE13@xxxxxxxxxxxxxx>
openSUSE Security Update: krb5: security update for remote denial-of-service
vulnerability
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0292-1
Rating: moderate
References: #596826
Cross-References: CVE-2010-1321
Affected Products:
openSUSE 11.2
openSUSE 11.1
openSUSE 11.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update fixes a denial-of-service vulnerability in
kadmind. A remote attack can send a malformed GSS-API token
that triggers a NULL pointer dereference. (CVE-2010-1321:
CVSS v2 Base Score: 6.8 (MEDIUM)
(AV:N/AC:L/Au:S/C:N/I:N/A:C))


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.2:

zypper in -t patch krb5-2443

- openSUSE 11.1:

zypper in -t patch krb5-2443

- openSUSE 11.0:

zypper in -t patch krb5-2443

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.2 (i586 src x86_64):

krb5-1.7-6.6.1

- openSUSE 11.2 (i586 x86_64):

krb5-apps-clients-1.7-6.6.1
krb5-apps-servers-1.7-6.6.1
krb5-client-1.7-6.6.1
krb5-devel-1.7-6.6.1
krb5-plugin-kdb-ldap-1.7-6.6.1
krb5-plugin-preauth-pkinit-1.7-6.6.1
krb5-server-1.7-6.6.1

- openSUSE 11.2 (x86_64):

krb5-32bit-1.7-6.6.1
krb5-devel-32bit-1.7-6.6.1

- openSUSE 11.1 (i586 ppc src x86_64):

krb5-1.6.3-132.8.1

- openSUSE 11.1 (i586 ppc x86_64):

krb5-apps-clients-1.6.3-132.8.1
krb5-apps-servers-1.6.3-132.8.1
krb5-client-1.6.3-132.8.1
krb5-devel-1.6.3-132.8.1
krb5-plugin-kdb-ldap-1.6.3-132.8.1
krb5-plugin-preauth-pkinit-1.6.3-132.8.1
krb5-server-1.6.3-132.8.1

- openSUSE 11.1 (x86_64):

krb5-32bit-1.6.3-132.8.1
krb5-devel-32bit-1.6.3-132.8.1

- openSUSE 11.1 (src):

krb5-plugins-1.6.3-132.8.1

- openSUSE 11.1 (ppc):

krb5-64bit-1.6.3-132.8.1
krb5-devel-64bit-1.6.3-132.8.1

- openSUSE 11.0 (i586 ppc src x86_64):

krb5-1.6.3-50.11

- openSUSE 11.0 (i586 ppc x86_64):

krb5-apps-clients-1.6.3-50.11
krb5-apps-servers-1.6.3-50.11
krb5-client-1.6.3-50.11
krb5-devel-1.6.3-50.11
krb5-plugin-kdb-ldap-1.6.3-9.8
krb5-plugin-preauth-pkinit-1.6.3-9.8
krb5-server-1.6.3-50.11

- openSUSE 11.0 (x86_64):

krb5-32bit-1.6.3-50.11
krb5-devel-32bit-1.6.3-50.11

- openSUSE 11.0 (src):

krb5-plugins-1.6.3-9.8

- openSUSE 11.0 (ppc):

krb5-64bit-1.6.3-50.11
krb5-devel-64bit-1.6.3-50.11


References:

http://support.novell.com/security/cve/CVE-2010-1321.html
https://bugzilla.novell.com/596826


< Previous Next >
This Thread
  • No further messages