Mailinglist Archive: opensuse-translation (78 mails)

< Previous Next >
[opensuse-translation] Testing Lokalize [Was: My kbabel does not spell check]
  • From: "Carlos E. R." <carlos.e.r@xxxxxxxxxxxx>
  • Date: Fri, 26 Sep 2008 18:01:48 +0200 (CEST)
  • Message-id: <alpine.LSU.2.00.0809261724000.27352@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



The Friday 2008-09-26 at 15:26 +0200, Martin Schlander wrote:

Fredag 26 september 2008 14:42:15 skrev Carlos E. R.:
The Friday 2008-09-26 at 14:46 +0300, Nick Shaforostoff wrote:
you might want to try Lokalize. if you do, you'll have to rebuild
translation memory only once, when migrating from KDE 4.1 to 4.2, as I
have changed database schema (to include filepath info and XLIFF
markup).

(Lokalize is kaider with changed name)

I'd like to, but I have the kde 3 (4 not yet) from the 11.0 install DVD,
and I have always been afraid of upgrading kde from the repos.

KDE4 is not an upgrade of KDE3. You install KDE4 alongside KDE3. Installing
KDE4 applications will not hurt the rest of your system in any way.

I know.

However, it does hurt: I have lost konqueror version 3, for instance. Running "konqueror" runs the 4.0.4 version, I have lost the kde 3 version (even though there are two menu entries for "konqueror", both run the kde4 version) and who knows what more.

That's what I was afraid of. It happened in 10.3, and it hapens again in 11.0


If you have installed a full 11.0 "KDE3" installation, you already have KDE4
versions of games, KTorrent, opensuseupdater etc.

If you don't want to risk an unsupported upgrade your few kde 4.0 apps/libs to
4.1 versions, Lokalize is available, built for 4.0 here
http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.0

I now have:


http://download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/Desktop/openSUSE_11.0/

http://download.opensuse.org/repositories/KDE:/KDE4:/STABLE:/Extra-Apps/openSUSE_11.0/
http://download.opensuse.org/repositories/KDE:/KDE4:/Community/openSUSE_11.0/

plus:
http://download.opensuse.org/repositories/KDE:/Backports/openSUSE_11.0/

I have installed lokalize (version 0.2 from above repos). It looks promising, but I'm dissapointed.

I can't edit the headers, for instance. I don't see when a message is marked fuzzy: if I activate the leds, they use 1.5 cm * 15 cm of screen space! (size can not be changed). There is no contextual help on the configurable items (what is "ID"? It is set to "kde-en_US". What is "templates"? What is Branch?) Going to "help" shows the contents page for lokalize, not the contextual help. Icons in configuration show question marks, not the icons.

The spell checking defaults to English enven though configurated language for project is Spanish. I change, exit, enter again, and again language is English (yes, of course, my desktop is English: I will not change that). The dictionary _must_ use the language of the project, or save the preferences. An incorrect text shows as black on dark grey background (unreadable) and red. There is no text listing the error (spelling? syntax? accels?) like kbabel.

I tried to load the translation memory, which I assume is equivalent to the translation database in kbabel. I tried to train it (double click on a path tree does not expand it, I have to press '+'), and lokalize crashed after a minute of 100% cpu, with no message that it was processing anything.

On exit, it prints the error to console:

** (process:29943): WARNING **: 1 dictionaries weren't free'd.


IMO, Lokalize is far from usable (it has to be better than kbabel). And as this it the only application for which I need kde 4, I will remove kde 4 again.

I'm sorry.


- -- Cheers,
Carlos E. R.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)

iEYEARECAAYFAkjdB3AACgkQtTMYHG2NR9UzUACfcIk1X/CD3HbNwV4HID9MPYXU
GygAn25avH5KINqJVWkrZqJXjIpBe0Ov
=jWYX
-----END PGP SIGNATURE-----
--
To unsubscribe, e-mail: opensuse-translation+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-translation+help@xxxxxxxxxxxx

< Previous Next >