Mailinglist Archive: opensuse-support (220 mails)

< Previous Next >
Re: [opensuse-support] Perl problem in SpamAssassin, uninitialized value.
On 29/01/2019 12.02, David Haller wrote:
Hello,

On Tue, 29 Jan 2019, Dave Howorth wrote:
On Tue, 29 Jan 2019 00:07:49 +0100 (CET)"Carlos E. R."
<robin.listas@xxxxxxxxxxxxxx> wrote:
[..]
processing message <26edd7a4-9c65-0a7d-2d7d-289...> for cer:1000
<2.4> 2019-01-28 23:40:32 Telcontar spamd 16758 - - Use of
uninitialized value $4 in concatenation (.) or string
at /usr/lib/perl5/vendor_perl/5.26.1/Mail/SpamAssassin/Plugin/URIDNSBL.pm
line 1044.
[..]
It refers to this code:

sub lookup_dnsbl_for_ip {
my ($self, $pms, $obj, $ip) = @_;

local($1,$2,$3,$4);
$ip =~ /^(\d+)\.(\d+)\.(\d+)\.(\d+)$/;
my $revip = "$4.$3.$2.$1"; <============

[..]
And your question/point is?

Hint: what is the value of $ip?
Extra hint: try adding:
warn "ip='$ip'\n" unless defined $1;

BTW: the code in 3.4.2 is the same, just if you're using an older version.

Hm.

https://bz.apache.org/SpamAssassin/show_bug.cgi?id=7339


Thus it is a known bug upstream, and I don't need to report it on our
bugzilla. Thanks.

Or is a patch needed?

Wait, it was reported on 2016. Still not solved? :-o

What is the output of:
perl -MNet::DNS -e 'print "$Net::DNS::VERSIONn";'


cer@Telcontar:~> perl -MNet::DNS -e 'print "$Net::DNS::VERSIONn";'
cer@Telcontar:~>

What SUSEn do you use?

The one in the signature, 15.0

cer@Telcontar:~> rpm -q spamassassin
spamassassin-3.4.1-lp150.5.3.x86_64
cer@Telcontar:~>

--
Cheers / Saludos,

Carlos E. R.
(from 15.0 x86_64 at Telcontar)

< Previous Next >
Follow Ups