Mailinglist Archive: opensuse-support (116 mails)

< Previous Next >
Re: [opensuse-support] Re: fwupd problems on DELL XPS 13
Hi Andrei,

thx for your answer.

17.12.2018 19:00, Michael Hirmke ?????:
Hi again,

should have mentioned, that secureboot is active!


Have your tried to disable it for FW update?

No, because I suspect, that I have to create a new boot entry with a non
secure image, then. And I wanted to avoid that in the first place.

[...]
Open bug report. fwupd expects file with name fwupdx64.efi.signed when
secure boot is enabled, while fwupdate (which builds fwupdx64.efi)
openSUSE build signs main binary fwupdx64.efi using OBS toolkit.

Ok.

Could you test

ln -s fwupdx64.efi fwupdx64.efi.signed

with SB enabled? That sounds like the simplest fix.

Good idea - I will try that.

[...]
Are you sure there are updates for your system in the first place? I
have Latitude E5450 and although it is recognized by fwupd, it does not
show any available updates.

There was a much newer firmware than the original one my notebook had.
Meanwhile I installed it via BIOS flash utility.
But when I tried fwupd, the original/older firmware was still in place.

Bye.
Michael.
--
Michael Hirmke
--
To unsubscribe, e-mail: opensuse-support+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse-support+owner@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References